lab 2 EIGRP Default Route

EIGRP发布默认路由的四种方式
  • Redistributed default route

    #R1#
    router eigrp 100
    redistribute static
     network 10.1.1.1 0.0.0.0no auto-summary
    ip route 0.0.0.0 0.0.0.0 202.100.1.10
    

     

     

  • By using ip summary-address command

    #interface FastEthernet1/0ip address 10.1.1.1 255.255.255.0
    ip summary-address eigrp 100 0.0.0.0 0.0.0.0 5

     

  • Default route by using ip default-network command

    R1(config)#ip default-network 202.100.1.0(
    写成主类
    这样就可以把这条路由下发给其它的路由器当做默认路由了使用本命令要满足以下条件:
    1、接口IP地址必须是主类
    2、接口必须宣告进EIGRP
    3、使用命令下发时也必须写主类网络号

     

  • Default route with network 0.0.0.0 command

    R1#router eigrp 100network 1.1.1.1 0.0.0.0network 10.1.1.1 0.0.0.0network 0.0.0.0no auto-summaryip route 0.0.0.0 0.0.0.0 FastEthernet0/0(
    写下一跳不行,必须写接口

     

基本网络配置

 

R2#
interface FastEthernet0/0ip address 10.1.1.10 255.255.255.0
R1#
 
interface FastEthernet0/0ip address 202.100.1.1 255.255.255.0
 
interface FastEthernet1/0ip address 10.1.1.1 255.255.255.0
 
ip route 0.0.0.0 0.0.0.0 202.100.1.10
 
Interne#
 
interface FastEthernet0/0ip address 202.100.1.10 255.255.255.0
 
ip route 0.0.0.0 0.0.0.0 202.100.1.1

 

 

Redistributed default route配置

 

 

R1#
router eigrp 100
redistribute static
 network 10.1.1.1 0.0.0.0no auto-summary

 

 

验证

#R2#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static routeGateway of last resort is 10.1.1.1 to network 0.0.0.010.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
D*EX 0.0.0.0/0 [170/307200] via 10.1.1.1, 00:17:42, FastEthernet0/0
 
#

 

 

Default route By using ip summary-address command配置

R1#
router eigrp 100network 10.1.1.1 0.0.0.0no auto-summary
 
interface FastEthernet1/0ip address 10.1.1.1 255.255.255.0
ip summary-address eigrp 100 0.0.0.0 0.0.0.0 5

 

 

验证

R2#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static routeGateway of last resort is 10.1.1.1 to network 0.0.0.010.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
D* 0.0.0.0/0 [90/284160] via 10.1.1.1, 00:00:05, FastEthernet0/0

 

 

Default route by using ip default-network command配置

  • The EIGRP default route can be created with the ip default-network network-number command. The classful destination network.

  • the network must either be an EIGRP-derived network in the routing table or be generated using a static route, which has been redistributed into EIGRP

  • the ip default-network command does not benefit router R1 directly.

R1#router eigrp 100network 10.1.1.1 0.0.0.0network 202.100.1.0no auto-summary
 ip default-network 202.100.1.0 
ip route 0.0.0.0 0.0.0.0 202.100.1.10

 

 

验证

R2#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route
Gateway of last resort is 10.1.1.1 to network 202.100.1.0
     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/409600] via 10.1.1.1, 00:04:01, FastEthernet0/0
D* 202.100.1.0/24 [90/307200] via 10.1.1.1, 00:00:14, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

 

 

Default route with network 0.0.0.0 command配置

if the network 0.0.0.0 command is added to the EIGRP configuration, it redistributes a default route as a result of the ip route 0.0.0.0 0.0.0.0 interface command.
R1#router eigrp 100
 network 1.1.1.1 0.0.0.0network 10.1.1.1 0.0.0.0
network 0.0.0.0
 no auto-summary
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0

 

 

验证

R2#show ip route 
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGPD - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2E1 - OSPF external type 1, E2 - OSPF external type 2i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2ia - IS-IS inter area, * - candidate default, U - per-user static routeo - ODR, P - periodic downloaded static route
Gateway of last resort is 10.1.1.1 to network 0.0.0.0
     1.0.0.0/24 is subnetted, 1 subnets
D       1.1.1.0 [90/409600] via 10.1.1.1, 00:10:37, FastEthernet0/0
D    202.100.1.0/24 [90/307200] via 10.1.1.1, 00:00:30, FastEthernet0/010.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0
D* 0.0.0.0/0 [90/307200] via 10.1.1.1, 00:00:02, FastEthernet0/0

 

 

 

 

 

 

 



来自为知笔记(Wiz)



转载于:https://www.cnblogs.com/faerl/p/8253740.html

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/571291.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

今天英雄联盟服务器维护要到好久,lol今天维护时间是多久 lol维护公告2020最新...

英雄联盟今天维护到几点?今日维护时间是多久?lol维护公告2020最新消息来啦!英雄联盟在4月16日凌晨1点进行了游戏的停机更新。下面,就和小编一起来了解一下最新的维护内容吧!lol10.8版本维护到几点LOL将在4月16日凌晨1点关闭排位赛入口(不影响已经在进行中的对局)&…

开关怎么使用_水龙头漏水怎么办?使用时把控开关力度很重要

水龙头漏水是家居生活中器件中常见的故障之一,导致水龙头漏水的原因有很多,严重就需要我们更换新的水龙头了。水龙头漏水怎么办呢?其实,我们掌握一些家居生活的知识也是对我们很有帮助的,下面是水龙头漏水的解决办法以及预防措施…

黑域,黑阈 Permission denied

在执行: adb -d shell sh /data/data/me.piebridge.brevent/brevent.sh 时遇到Permission denied,多运行一次就好了。 完整的有两条命令: adb devicesadb -d shell sh /data/data/me.piebridge.brevent/brevent.sh 转载于:https://www.cnblog…

fast路由器服务器未响应,win7系统下fast路由器进不了设置界面如何解决

最近有不少win7纯净版系统用户到本站反馈说碰到这样一个问题,就是在使用fast路由器的时候,进不了设置界面,导致无法进行一系列设置,该怎么办呢,接下来给大家讲解一下win7系统下fast路由器进不了设置界面的具体解决方法…

xshell堡垒机_Jumpserver开源堡垒机管理

此篇文章主要介绍jumpserver开源堡垒机管理,安装请移至:Jumpserver开源堡垒机安装一、用户管理1)添加用户1输入要添加的用户名,姓名,权限,Mail,并且发送邮件 —> 确认保存23查看添加的用户4查看用户邮件…

解决连接mysql报错1130

最近在服务器上部署好的应用突然间连接不上mysql数据库,报错“ERROR 1130: Host xxx.xxx.xxx.xxx is not allowed to connect to this MySQL server” 那么直接运行如下命令: mysql -u root -p 弹出Enter password:输入您的数据库密码 链接到mysql数据库…

python 多组直方图 画图_python – 使用matplotlib的多个并排直方图?

我有一个软件必须处理大量不同的数据,并且可能需要不同的时间来处理它.随着软件的修改,处理数据所需的时间也会发生变化,所以我想创建一个显示时间差异和异常值的图表,因为理想情况下,这个程序每个部分需要大约相同的时间数据(这听起来很奇怪,不切实际,我知道,但在这里和我一起…

vnc连接服务器怎么配置文件,vnc服务器和客户端怎么配置文件

vnc服务器和客户端怎么配置文件 内容精选换一换用户通过psycopy2连接GaussDB(for openGauss)服务器时,可以通过开启SSL加密客户端和服务器之间的通讯。在使用SSL时,默认用户已经获取了服务端和客户端所需要的证书和私钥文件,关于证书等文件的…

shell题库选择题_shell学习:几道常见shell习题

1. 编写shell脚本,计算1-100的和;1 #! /bin/bash2 sum03 for i in seq 1 100; do4 sum$[$i$sum]5 done6 echo $sum计算-00和2. 编写shell脚本,要求输入一个数字,然后计算出从1到输入数字的和,要求,如果输入…

服务器主板稳定,服务器主板

Intel Atom™ C3000 Mini-ITX 服务器主板,带 4 个DDR4 DIMM, 1 个 PCIe x4插槽 (Gen 3.0), 8 个SATA III, IPMILGA 1151 Intel Xeon E3 v5/ v6 Core™ i 6代/7代 Micro ATX 服务器主板,带4 个DDR4,1 个PCIe x 16,3 个PCIe x 4&am…

Extjs grid 设置行字体颜色

CustSuppGrid Ext.create(Ext.grid.Panel, {title : , // 标题头iconCls : icon-grid, // 标题图标store : CustSuppStore, // 数据源frame : false, // True 为 Panel 填充画面,默认为falseforceFit : false, // 设置为true,则强制列自适应成可用宽度selType : checkboxmodel…

诚龙网刻报错_诚龙PXE网刻工具11.5

终于等到您!马上注册登录,做有身份的人!您需要 登录 才可以下载或查看,没有帐号?注册账号扫一扫,用微信登录x使用诚龙网维全自动PXE网刻工具进行网刻,你无须架设DHCP和TFTP服务器,也无须进行GHS…

e3 v3服务器芯片组,请问e3 1231 v3搭配下面哪款主板性价比最高?最适合?为什么?

CPU是插在主板上的,因此主板给CPU的电要足。越高级的CPU,工作时频率越高,核心数越多,需要的电就越多。如果是两相的CPU供电,假设是i3,够用。如果是i7,当你的电脑运行软件多的时候,比…

activemq控制发送频率_发送activemq

ActiveMQ入门实例1.下载ActiveMQ去官方网站下载:http://activemq.apache.org/2.运行ActiveMQ解压缩apache-activemq-5.5.1-bin.zip,然后双击apache-activemq-5.5.1\bin\activemq.bat运行ActiveMQ程序...文章嗯哼99252017-12-261030浏览量Spring-boot项目…

Linux学习(一)

从零开始学习linux,这里不多写虚拟机的安装以及centos的设置,简单粗暴从命令行开始; 一、目录介绍 /bin  存放必要的命令 /boot  存放内核以及启动所需的文件 /dev  存放设备文件 /etc  存放系统配置文件 /home  普通用户的宿主目录…

打印机服务器ip修改,怎么样更改打印机服务器的ip地址

怎么样更改打印机服务器的ip地址 内容精选换一换实例常用端口如表1所示。您可以通过配置安全组规则放通实例对应的端口,详情请参见配置安全组规则。无法访问公有云某些端口问题现象:访问公有云特定端口,在部分地区部分运营商无法访问&#xf…

nginx只能访问80端口_nginx 访问不了非80端口

在CentOS服务器上装好了nginx,直接通过公网ip可以正常显示nginx 的 index.html页面。同时我在3000端口跑了node应用,现在我想通过 公网ip:8089的形式访问nginx的配置代码:server {listen 8089;server_name 公网ip;location / {root /usr/web;…

Python中os模块使用方法

os模块提供了对系统环境、文件、目录等操作系统级的接口函数。本文主要描述os模块和os.path模块常用函数以及常用实例。 os模块函数 os.getcwd() 获取当前工作的目录。 os.listdir(dirname) 获取指定目录下的文件和目录,以列表形式输出 os.makedirs(dirname1/dirnam…

66319d电源使用说明书_电热水壶怎么使用?电热水壶烧不开水的问题是什么?

电热水壶可在最短的时间里面给人们煮出热水,是目前人们见到的最为常见的小家电产品,但是电热水壶怎么使用?在使用电热水壶时,有遇到烧不开水的问题,这就影响到正常使用水壶了,电热水壶烧不开水的问题是什么?一、电热…

django 项目中遇到的问题(持续更新中)

问题1:in include provide the namespace argument to include() instead 描述:在最外层的urls.py 添加项目的urls后报错,错误显示:in include provide the namespace argument to include() instead." 解决方案:…