C++学习之路 | PTA(甲级)—— 1114 Family Property (25分)(带注释)(并查集)(精简)

1114 Family Property (25分)
This time, you are supposed to help us collect the data for family-owned property. Given each person’s family members, and the estate(房产)info under his/her own name, we need to know the size of each family, and the average area and number of sets of their real estate.
Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤1000). Then N lines follow, each gives the infomation of a person who owns estate in the format:
ID Father Mother k Child
​1
​​ ⋯Child
​k
​​ M
​estate
​​ Area
where ID is a unique 4-digit identification number for each person; Father and Mother are the ID’s of this person’s parents (if a parent has passed away, -1 will be given instead); k (0≤k≤5) is the number of children of this person; Child
​i
​​ 's are the ID’s of his/her children; M
​estate
​​ is the total number of sets of the real estate under his/her name; and Area is the total area of his/her estate.
Output Specification:

For each case, first print in a line the number of families (all the people that are related directly or indirectly are considered in the same family). Then output the family info in the format:
ID M AVG
​sets
​​ AVG
​area
​​
where ID is the smallest ID in the family; M is the total number of family members; AVG
​sets
​​ is the average number of sets of their real estate; and AVG
​area
​​ is the average area. The average numbers must be accurate up to 3 decimal places. The families must be given in descending order of their average areas, and in ascending order of the ID’s if there is a tie.
Sample Input:

10
6666 5551 5552 1 7777 1 100
1234 5678 9012 1 0002 2 300
8888 -1 -1 0 1 1000
2468 0001 0004 1 2222 1 500
7777 6666 -1 0 2 300
3721 -1 -1 1 2333 2 150
9012 -1 -1 3 1236 1235 1234 1 100
1235 5678 9012 0 1 50
2222 1236 2468 2 6661 6662 1 300
2333 -1 3721 3 6661 6662 6663 1 100
Sample Output:

3
8888 1 1.000 1000.000
0001 15 0.600 100.000
5551 4 0.750 100.000

#include<iostream>
#include<set>
#include<vector>
#include<map>
#include<algorithm>
using namespace std;
const int maxn = 10000;
int pre[maxn];
struct node {//存储开始输入的人的基本信息int id, house;double area;
};
struct family {//输出的家庭结构体int id, number;double house, area;
};
bool cmp(family a, family b)//自定义比较函数
{if (a.area != b.area)return a.area > b.area;else return a.id < b.id;
}
int find(int x)//并查集模板,查找
{while (x != pre[x]) x = pre[x];return x;
}
void merge(int x, int y)//并查集模板,合并
{int a = find(x);int b = find(y);if (a != b) pre[a] = b;
}
int main()
{int n, x;cin >> n;set<int>s;//存储每人的编号,默认升序map<int, node>nodes;//记录人的房产信息for (int i = 0; i < maxn; i++)pre[i] = i;//初始化pre数组for (int i = 0; i < n; i++){int id, p1, p2, k, house, id1;//分别记录编号 父 母 k 孩子1 ... 孩子k 房产套数double area;// 总面积cin >> id >> p1 >> p2 >> k;s.insert(id);//插入idif (p1 != -1)//有爸爸{s.insert(p1);merge(id, p1);}if (p2 != -1)//有妈妈{s.insert(p2);merge(id, p2);}for (int j = 0; j < k; j++)//随后的家庭成员{cin >> id1;s.insert(id1);merge(id1, id);}cin >> house >> area;nodes[id] = node{ id,house,area };//记录该人的家庭信息}set<int>s1;//记录家庭编号(也可以理解记录着每个家庭的老大)map<int, vector<int>>m;//记录家庭编号()和成员编号for (auto it = s.begin(); it != s.end(); it++){int fa = find(*it);m[fa].push_back(*it);s1.insert(fa);}cout << s1.size() << endl;//输出家庭的个数vector<family>v1;for (auto it = s1.begin(); it != s1.end(); it++){int fa = *it;double house = 0, area = 0;for (auto tmp = 0; tmp < m[fa].size(); tmp++)//将每个家庭的成员及其房产计算汇总,放入family结构体中{house += nodes[m[fa][tmp]].house;area += nodes[m[fa][tmp]].area;}v1.push_back(family{ m[fa][0],int(m[fa].size()),house * 1.0 / (int)m[fa].size(),area * 1.0 / (int)m[fa].size() });}sort(v1.begin(), v1.end(), cmp);//进行排序for (int i = 0; i < v1.size(); i++) {printf("%04d %d %.3lf %.3lf", v1[i].id, v1[i].number, v1[i].house, v1[i].area);if (i < v1.size() - 1) puts("");}
}

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/news/497137.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

拥抱AI大趋势,ARM发布两款AI芯片架构

来源&#xff1a;量子位概要&#xff1a;ARM发布了两款针对移动终端的AI芯片架构&#xff0c;物体检测&#xff08;Object Detection&#xff0c;简称OD&#xff09;处理器和机器学习&#xff08;Machine Learning&#xff0c;简称ML&#xff09;处理器。今天&#xff0c;ARM发…

Ubuntu 安装 mysql、sqlite3、postgresql

NAVICAT 官网&#xff1a;http://www.navicat.com.cn/products NAVICAT16 PREMIUM NAVICAT16 &#xff1a;http://zzzzzz.me/post-73329.html Xmanager &#xff1a;https://www.xshellcn.com/ 1、Ubuntu 安装 mysql ubuntu上安装MySQL非常简单只需要几条命令就可以完成。 1…

牡丹园

其实从少林寺去洛阳非常近&#xff0c;当时想赶当天晚上的火车去另一个地方&#xff0c;所以从少林寺又回到郑州火车站&#xff0c;结果没有票&#xff0c;于是取消了。决定在郑州住一晚第二天去洛阳。 看到洛阳路边隔断种的都是这种植物&#xff0c;星星点点很是好看&#xff…

Singleton 和 Monostate 模式

Singleton 和 Monostate 模式 怎样才能使得两个实例表现得像一个对象呢&#xff1f;很简单&#xff0c;只要把所有的变量都变成静态变量即可。 public class Monostate {private static int itsX 0;public Monostate() {}public void setX(final int x) {itsX x;}public int…

十张图看懂未来大数据世界

作者&#xff1a;薄云借智来源&#xff1a;钱塘江大数据随着互联网云时代的来临&#xff0c;大数据与云计算就像一个硬币的正反两面&#xff0c;势必会影响到社会生活的方方面面&#xff0c;改变我们现有的规则和秩序。伴随着大数据与云计算产业的不断发展&#xff0c;未来到底…

MediaWiki初探:安装及使用入门

来源&#xff1a;http://blog.csdn.net/wangnan537/article/details/37743497 MediaWiki是著名的开源wiki引擎&#xff0c;全球最大的wiki项目维基百科(百科词条协作系统)是使用MediaWiki的成功范例&#xff0c;MediaWiki的最大作用在于对知识的归档&#xff0c;可用于构建企业…

科学释梦——意识窗口在记忆模块间的穿越

作者&#xff1a;谢平 中国科学院大学教授 唐代诗人李白曾说&#xff0c;“浮生若梦&#xff0c;为欢几何”&#xff0c;将人生喻为短暂的梦幻。有些人生如梦&#xff0c;有些梦若人生&#xff0c;还有梦想人生......梦——五彩缤纷&#xff0c;诡异神奇&#xff0c;我们每晚都…

asp.net 一个简易权限的小例子设计

asp.net 一个简易权限的小例子设计 近日在阅读一本asp.net的书时&#xff08;国人写的&#xff09;&#xff0c;其中提到了一个简易权限的小例子&#xff0c;感觉说的还是比较清楚&#xff0c;有点代表性&#xff0c;故在此简单介绍下其实现原理其核心是建立起用户、角色&#…

linux 内核与用户空间通信之netlink使用方法

Linux中的进程间通信机制源自于Unix平台上的进程通信机制。Unix的两大分支AT&T Unix和BSD Unix在进程通信实现机制上的各有所不同&#xff0c;前者形成了运行在单个计算机上的System V IPC&#xff0c;后者则实现了基于socket的进程间通信机制。同时Linux也遵循IEEE制定的P…

C++学习之路 | PTA乙级—— 1020 月饼 (25分)(带注释)(精简)

1024 科学计数法 (20分) 科学计数法是科学家用来表示很大或很小的数字的一种方便的方法&#xff0c;其满足正则表达式 [][1-9].[0-9]E[][0-9]&#xff0c;即数字的整数部分只有 1 位&#xff0c;小数部分至少有 1 位&#xff0c;该数字及其指数部分的正负号即使对正数也必定明确…

超级智能城市:更高质量的幸福社会

报告下载链接:https://pan.baidu.com/s/1oAmRK4U 密码:t9qb未来智能实验室是人工智能学家与科学院相关机构联合成立的人工智能&#xff0c;互联网和脑科学交叉研究机构。由互联网进化论作者&#xff0c;计算机博士刘锋与中国科学院虚拟经济与数据科学研究中心石勇、刘颖教授创建…

切洋葱怎么才不流泪?

切洋葱时&#xff0c;由于洋葱有一种挥发物质&#xff0c;常使切菜的人流泪。防止的方法是&#xff1a; 1.在切洋葱前&#xff0c;把切菜刀在冷水中浸一会儿&#xff0c;再切时就不会因受挥发物质刺激而流泪了。 2.将洋葱对半切开后,先泡一下凉水再切,就不会流泪了. 3.放微波炉…

python网络编程——IO多路复用之epoll

来源&#xff1a;http://www.cnblogs.com/maociping/p/5132583.html 1、内核EPOLL模型讲解 此部分参考http://blog.csdn.net/mango_song/article/details/42643971博文并整理 首先我们来定义流的概念&#xff0c;一个流可以是文件&#xff0c;socket&#xff0c;pipe等可以进行…

高精度定位!“天地一体”基础设施助中国北斗在商用领域“弯道超车”

来源&#xff1a;上观概要&#xff1a;从2007年第一颗北斗导航卫星成功发射&#xff0c;到2018年2月12日第二十八、二十九颗卫星顺利升空进入预定轨道&#xff0c;北斗导航卫星系统的产业化步伐也日益加快。从2007年第一颗北斗导航卫星成功发射&#xff0c;到2018年2月12日第二…

DotNet 网上相关资源

相关网站列表 http://blog.joycode.com/ 博客堂 主要是微软专家的帖子&#xff0c;内容较新 http://www.cnblogs.com/ 博客园 http://www.microsoft.com/resources/practices/default.mspx 模式和实践首页 http://msdn.microsoft.com/smartclient/ 智能客户端首页 http://msdn…

2018全球技术展望报告

来源&#xff1a;199IT互联网数据中心概要&#xff1a;随着人工智能&#xff08;AI&#xff09;和其他技术的飞速发展&#xff0c;智能企业层出不穷&#xff0c;并正融入人们的生活。埃森哲&#xff08;纽交所代码&#xff1a;ACN&#xff09;最新发布的《埃森哲技术展望2018》…