题干:
In a modernized warehouse, robots are used to fetch the goods. Careful planning is needed to ensure that the robots reach their destinations without crashing into each other. Of course, all warehouses are rectangular, and all robots occupy a circular floor space with a diameter of 1 meter. Assume there are N robots, numbered from 1 through N. You will get to know the position and orientation of each robot, and all the instructions, which are carefully (and mindlessly) followed by the robots. Instructions are processed in the order they come. No two robots move simultaneously; a robot always completes its move before the next one starts moving.
A robot crashes with a wall if it attempts to move outside the area of the warehouse, and two robots crash with each other if they ever try to occupy the same spot.
Input
The first line of input is K, the number of test cases. Each test case starts with one line consisting of two integers, 1 <= A, B <= 100, giving the size of the warehouse in meters. A is the length in the EW-direction, and B in the NS-direction.
The second line contains two integers, 1 <= N, M <= 100, denoting the numbers of robots and instructions respectively.
Then follow N lines with two integers, 1 <= Xi <= A, 1 <= Yi <= B and one letter (N, S, E or W), giving the starting position and direction of each robot, in order from 1 through N. No two robots start at the same position.
Figure 1: The starting positions of the robots in the sample warehouse
Finally there are M lines, giving the instructions in sequential order.
An instruction has the following format:
< robot #> < action> < repeat>
Where is one of
- L: turn left 90 degrees,
- R: turn right 90 degrees, or
- F: move forward one meter,
and 1 <= < repeat> <= 100 is the number of times the robot should perform this single move.
Output
Output one line for each test case:
- Robot i crashes into the wall, if robot i crashes into a wall. (A robot crashes into a wall if Xi = 0, Xi = A + 1, Yi = 0 or Yi = B + 1.)
- Robot i crashes into robot j, if robots i and j crash, and i is the moving robot.
- OK, if no crashing occurs.
Only the first crash is to be reported.
Sample Input
4 5 4 2 2 1 1 E 5 4 W 1 F 7 2 F 7 5 4 2 4 1 1 E 5 4 W 1 F 3 2 F 1 1 L 1 1 F 3 5 4 2 2 1 1 E 5 4 W 1 L 96 1 F 2 5 4 2 3 1 1 E 5 4 W 1 F 4 1 L 1 1 F 20
Sample Output
Robot 1 crashes into the wall Robot 1 crashes into robot 2 OK Robot 1 crashes into robot 2
题目大意:
机器人移动。给你一些机器人的初始位置和朝向和一些移动指令。要你判断在指令执行的过程中是否有机器人撞墙或者两个机器人相撞的情况。
解题报告:
直接模拟就行了。当时因为在,左右转的那里,to = r[num].dir;写成了to=go(op[0]),所以WA了。还是要注意细节啊!!
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
int maze[105][105];
int a,b;
int n,m;
int nx[4] = {1,0,-1,0};//右,下,左,上
int ny[4] = {0,-1,0,1};//右,下,左,上
struct Node {int x,y;int dir;
} r[555];
int go(char x) {if(x == 'E') return 0;if(x == 'S') return 1;if(x == 'W') return 2;if(x == 'N') return 3;
}
int main()
{int t;int gg = 0;char op[5];cin>>t;while(t--) {gg = 0;int ans1,ans2;memset(maze,0,sizeof maze);scanf("%d%d",&a,&b);scanf("%d%d",&n,&m);//robot个数和指令数for(int i = 1; i<=n; i++) {scanf("%d%d%s",&r[i].x,&r[i].y,op);r[i].dir = go(op[0]);maze[r[i].x][r[i].y] = i;}for(int i = 1; i<=m; i++) {int num,rep;scanf("%d%s%d",&num,op,&rep);if(gg != 0) continue;int to;if(op[0] == 'F') {to = r[num].dir;for(int j = 1; j<=rep; j++) {int tx = r[num].x + nx[to];int ty = r[num].y + ny[to];if(tx < 1 || tx > a || ty < 1 || ty > b) {gg = 2;ans1 = num;break;}if(maze[tx][ty] != 0) {gg=1;//撞人了;ans1 = num;ans2 = maze[tx][ty];break;}maze[tx][ty] = num;maze[r[num].x][r[num].y]=0;r[num].x=tx;r[num].y=ty;} }else { to = r[num].dir;while(rep>4) rep-=4;for(int j = 1; j<=rep; j++) {if(op[0] == 'L') {to = (to+4-1)%4;}else to = (to+1)%4;}r[num].dir = to;}}if(gg == 1) {printf("Robot %d crashes into robot %d\n",ans1,ans2);}else if(gg == 2) {printf("Robot %d crashes into the wall\n",ans1);}else puts("OK");}return 0 ;
}