题干:
In Fuzhou, there is a crazy super man. He can’t fly, but he could jump from housetop to housetop. Today he plans to use N houses to hone his house hopping skills. He will start at the shortest house and make N-1 jumps, with each jump taking him to a taller house than the one he is jumping from. When finished, he will have been on every house exactly once, traversing them in increasing order of height, and ending up on the tallest house.
The man can travel for at most a certain horizontal distance D in a single jump. To make this as much fun as possible, the crazy man want to maximize the distance between the positions of the shortest house and the tallest house.
The crazy super man have an ability—move houses. So he is going to move the houses subject to the following constraints:
1. All houses are to be moved along a one-dimensional path.
2. Houses must be moved at integer locations along the path, with no two houses at the same location.
3. Houses must be arranged so their moved ordering from left to right is the same as their ordering in the input. They must NOT be sorted by height, or reordered in any way. They must be kept in their stated order.
4. The super man can only jump so far, so every house must be moved close enough to the next taller house. Specifically, they must be no further than D apart on the ground (the difference in their heights doesn't matter).
Given N houses, in a specified order, each with a distinct integer height, help the super man figure out the maximum possible distance they can put between the shortest house and the tallest house, and be able to use the houses for training.
Input
In the first line there is an integer T, indicates the number of test cases.(T<=500)
Each test case begins with a line containing two integers N (1 ≤ N ≤ 1000) and D (1 ≤ D ≤1000000). The next line contains N integer, giving the heights of the N houses, in the order that they should be moved. Within a test case, all heights will be unique.
Output
For each test case , output “Case %d: “first where d is the case number counted from one, then output a single integer representing the maximum distance between the shortest and tallest house, subject to the constraints above, or -1 if it is impossible to lay out the houses. Do not print any blank lines between answers.
Sample Input
3 4 4 20 30 10 40 5 6 20 34 54 10 15 4 2 10 20 16 13
Sample Output
Case 1: 3 Case 2: 3 Case 3: -1
题目大意:
有N个在一条直线上的房子, 每个房子有着不同的高度, 一个超人可以将这些房子左右移动 但不能改变房子之间的相对位置(只能把房子之间的距离拉开).
现在超人要从最矮的房子跳到刚好比他高的房子上面, 且每次跳的房子都要比当前房子要高.他要跳N-1次。
那么最后超人肯定会跳到最高的房子上面, 现在给出超人一次能够跳的最远距离D, 问: 如何摆放这些房子, 使得超人能够经过所有的房子跳到最高的房子, 又要使最矮的房子和最高的房子 之间的距离最远?
第一行一个整数T,表示数据组数,T≤500。
每组测试数据,第一行两个整数N和D
接下来一行N个,表示从左到右每个房子的依次高度。
求最矮的和最高的可以到达的最远距离。-1表示不可行。
解题报告:
直接差分约束建图,求最大差,建A-B<=C的形式跑最短路就行了。
设s[i]代表第i个的相对位置,初始化s[st]=0。
满足s[i] - s[i-1] >= 1 和 相邻高度的s[]的差<=d这两个条件即可。注意连边的时候要下标小的向大的连,而不是高度低的向高的连,因为你这里s[]数组代表的就是所在的位置,跟高度没啥关系,高度就是确认连边的两个点的。
AC代码:
#include<cstdio>
#include<iostream>
#include<algorithm>
#include<queue>
#include<map>
#include<vector>
#include<set>
#include<string>
#include<cmath>
#include<cstring>
#define F first
#define S second
#define ll long long
#define pb push_back
#define pm make_pair
using namespace std;
const int MAX = 2000 + 5;
const int INF = 0x3f3f3f3f;
int n,D;
struct Node {int id,h;bool operator<(const Node & b) const {return h < b.h;}
} W[MAX];
int tot,head[MAX];
struct Edge {int v,ne,w;
} e[MAX<<4];//应该<<1就够了?
void add(int u,int v,int w) {e[++tot].v = v;e[tot].w = w;e[tot].ne = head[u];head[u] = tot;
}
int vis[MAX],dis[MAX],cnt[MAX];
int spfa(int st,int ed) {for(int i = 1; i<=n; i++) dis[i]=INF,vis[i]=cnt[i]=0;queue<int> q;q.push(st);vis[st]=1,dis[st]=0;while(q.size()) {int cur = q.front();q.pop();vis[cur] = 0;for(int i = head[cur]; ~i; i = e[i].ne) {int v = e[i].v;if(dis[v] > dis[cur] + e[i].w) {dis[v] = dis[cur] + e[i].w;if(vis[v] == 0) {vis[v] = 1;cnt[v]++;if(cnt[v] > n) return -1;q.push(v);}}}}return dis[ed];
}
int main()
{int t,iCase=0;cin>>t;while(t--) {scanf("%d%d",&n,&D);tot=0;memset(head,-1,sizeof head);for(int i = 1; i<=n; i++) scanf("%d",&W[i].h),W[i].id = i;for(int i = 2; i<=n; i++) add(i,i-1,-1);sort(W+1,W+n+1);for(int x,y,i = 2; i<=n; i++) x=min(W[i-1].id,W[i].id),y=max(W[i-1].id,W[i].id),add(x,y,D);int x = min(W[1].id,W[n].id),y = max(W[1].id,W[n].id);int ans = spfa(x,y);printf("Case %d: %d\n",++iCase,ans);}return 0 ;
}