实现一个栈,栈初始为空,支持四种操作:
push x
– 向栈顶插入一个数 xx;pop
– 从栈顶弹出一个数;empty
– 判断栈是否为空;query
– 查询栈顶元素。
现在要对栈进行 M 个操作,其中的每个操作 3 和操作 4 都要输出相应的结果。
输入格式
第一行包含整数 M,表示操作次数。
接下来 M 行,每行包含一个操作命令,操作命令为 push x
,pop
,empty
,query
中的一种。
输出格式
对于每个 empty
和 query
操作都要输出一个查询结果,每个结果占一行。
其中,empty
操作的查询结果为 YES
或 NO
,query
操作的查询结果为一个整数,表示栈顶元素的值。
数据范围
1≤M≤100000,
1≤x≤109
所有操作保证合法。
输入样例:
10
push 5
query
push 6
pop
query
pop
empty
push 4
query
empty
输出样例:
5
5
YES
4
NO
_____________________________________________________________________________
用数组模拟栈,节省时间。
写作不易,点个赞呗!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
_____________________________________________________________________________
#include <bits/stdc++.h>
using namespace std;
int stk[1000005],n,idx=0;idx记录当前栈元素数量
string x;
void push(int x){加入元素stk[++idx]=x;
}
int top(){返回栈顶return stk[idx];
}
void pop(){删除栈顶元素idx--;
}
int empty(){判断栈是否为空if(idx==0)return 1;else return 0;
}
int main(){cin>>n;for(int i=1;i<=n;i++){int y;cin>>x;if(x[0]=='p'&&x[1]=='u'){cin>>y;push(y);}else if(x[0]=='q')cout<<top()<<endl;else if(x[0]=='e'){if(empty()==1)cout<<"YES"<<endl;else cout<<"NO"<<endl;}else if(x[0]=='p')pop();}
}
经过改进
#include <bits/stdc++.h>
using namespace std;
int stk[1000005],n,idx=0;
string x;
void push(int x){stk[++idx]=x;
}
void top(){cout<<stk[idx]<<endl;
}
void pop(){idx--;
}
void empty(){if(idx==0)cout<<"YES"<<endl;else cout<<"NO"<<endl;
}
int main(){cin>>n;for(int i=1;i<=n;i++){int y;cin>>x;if(x[0]=='p'&&x[1]=='u'){cin>>y;push(y);}else if(x[0]=='t')top();else if(x[0]=='e')empty();else if(x[0]=='p')pop();}
}
更优美啦