题意:有n个谷仓有n-1条路连接,问最少删除哪几个点才能使得删除点后得到的连通图的加点数不大于n/2.
分析:求树的重心的变形题,poj3107的简单版,一遍dfs从叶子到根转移找出找到以每个节点为根的子树的结点数,f[u]={ f[v1]+f[v2]+.....+f[vn] }+1;使得每棵子树节点数小于n/2,并且父节点得那个连通图节点数小于等于n/2,即n-f[u]<=n/2.
如果没有这样的点,输出NONE
Time limit 1000 ms
Memory limit 65536 kB
OS Linux
Source USACO 2004 December Silver
After Farmer John realized that Bessie had installed a "tree-shaped" network among his N (1 <= N <= 10,000) barns at an incredible cost, he sued Bessie to mitigate his losses.
Bessie, feeling vindictive, decided to sabotage Farmer John's network by cutting power to one of the barns (thereby disrupting all the connections involving that barn). When Bessie does this, it breaks the network into smaller pieces, each of which retains full connectivity within itself. In order to be as disruptive as possible, Bessie wants to make sure that each of these pieces connects together no more than half the barns on FJ.
Please help Bessie determine all of the barns that would be suitable to disconnect.
Input
* Line 1: A single integer, N. The barns are numbered 1..N.
* Lines 2..N: Each line contains two integers X and Y and represents a connection between barns X and Y.
Output
* Lines 1..?: Each line contains a single integer, the number (from 1..N) of a barn whose removal splits the network into pieces each having at most half the original number of barns. Output the barns in increasing numerical order. If there are no suitable barns, the output should be a single line containing the word "NONE".
Sample Input
10
1 2
2 3
3 4
4 5
6 7
7 8
8 9
9 10
3 8
Sample Output
3
8
Hint
INPUT DETAILS:
The set of connections in the input describes a "tree": it connects all the barns together and contains no cycles.
OUTPUT DETAILS:
If barn 3 or barn 8 is removed, then the remaining network will have one piece consisting of 5 barns and two pieces containing 2 barns. If any other barn is removed then at least one of the remaining pieces has size at least 6 (which is more than half of the original number of barns, 5).
题意:
给定一棵无向树,节点为n(n<=10000),问删除那些节点可以使得新图中的每一个连通分支的节点数都不超过小于n/2
思路:
树形dp,任意定跟,求出每个节点的儿子节点,每个点为根的子树的节点数dp[i],然后考察每一个点,如果n-dp[i]<=n/2,以及以i的每一个儿子为根的子树的节点数都dp[u]<=n/2,那么这个点就满足条件
/*题意:给了一棵节点数为n的树的对应关系,让判断去掉哪些
节点能使子数的大小小于等于n/2,并将符合条件的节点从小到
大输出,如果没有符合条件的节点,则输出 “NONE”。
思路:既然是让求哪些ji节点符合条件,可以用邻接表构建一个
图,然后用dfs找出每一个节点下连的图的da'x大小些节点符合
条件,将节点存入ans数组中。*/
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 10010
using namespace std;
int n,s,e,first[N],book[N],ans[N];
struct node
{int x,y;
}que[2*N];
void add(int x,int y) //构建邻接表的函数
{que[e].x=x;que[e].y=first[y];first[y]=e++;
}
int dfs(int x)
{int num=0,sum=0;book[x]=1;int k=first[x],flag=0;while(k!=-1){if(!book[que[k].x]){num=dfs(que[k].x);sum+=num;if(num>n/2) //x节点下的图的大小超过了n/2,不符合条件flag=1;}k=que[k].y;}if(n-sum-1>n/2) //另一半是否小于等于n/2flag=1;if(!flag)ans[s++]=x;return sum+1; //加上自己
}
int main()
{while(~scanf("%d",&n)){memset(first,-1,sizeof(first));//初始化memset(book,0,sizeof(book));s=e=0; //有s个节点符合条件,e用邻接表表示无向图的大小int a,b;for(int i=1;i<n;i++){scanf("%d%d",&a,&b);add(a,b); //构建邻接表add(b,a); //无向图}a=dfs(1); //从第一个点开始尝试if(s) //有s个节点符合条件{sort(ans,ans+s); //从小到大排序,输出for(int i=0;i<s;i++)printf("%d\n",ans[i]);}else //没有符合条件的节点printf("NONE\n");}
}