题意
给定 n个长度不超过 10的数字串,问其中是否存在两个数字串S,T ,使得 S是 T的前缀,多组数据。
题目
Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers:
Emergency 911
Alice 97 625 999
Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent.
Input
The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
Output
For each test case, output “YES” if the list is consistent, or “NO” otherwise.
Sample Input
2
3
911
97625999
91125426
5
113
12340
123440
12345
98346
Sample Output
NO
YES
分析
用字典树,第一个为空点**(++tot易错)**连接第一个数(0~9),每出现一个新点,插入字典书中。我的代码是在建树过程中找到出现的前缀,并记录。出现前缀有两种情况:
- .本身为树上某数字串的前缀,则在建树过程中没有出现新点。
- .树上的某数字串为当前数字串的前缀,则建树过程中,扫过数字串的末尾(可以用book数组标记数字串结尾)
搞了两天,终于弄懂了,相对还是容易的。 - 复杂度:O(nlogn+nlog2^{2}2n)
AC代码
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int N=6e5+10;
const int Z=50;
int T,n,tot,ch[N][Z];
char s[Z];
bool bo[N];
bool insert(char *s)
{int l=strlen(s);int u=1;bool flag=false;for(int i=0; i<l; i++){int c=s[i]-'0';if(!ch[u][c])ch[u][c]=++tot;else if(i==l-1)flag=true;u=ch[u][c];if(bo[u])flag=true;}bo[u]=true;return flag;
}
int main()
{scanf("%d",&T);while(T--){scanf("%d",&n);tot=1;memset(ch,0,sizeof(ch));memset(bo,false,sizeof(bo));bool ans=false;for(int i=1; i<=n; i++){scanf("%s",s);if(insert(s))ans=true;}if(ans)printf("NO\n");else printf("YES\n");}return 0;
}