题目:
将一系列给定数字顺序插入一个初始为空的小顶堆H[]。随后判断一系列相关命题是否为真。命题分下列几种:
x is the root:x是根结点;
x and y are siblings:x和y是兄弟结点;
x is the parent of y:x是y的父结点;
x is a child of y:x是y的一个子结点。
输入格式:
每组测试第1行包含2个正整数N(≤ 1000)和M(≤ 20),分别是插入元素的个数、以及需要判断的命题数。下一行给出区间[−10000,10000]内的N个要被插入一个初始为空的小顶堆的整数。之后M行,每行给出一个命题。题目保证命题中的结点键值都是存在的。
输出格式:
对输入的每个命题,如果其为真,则在一行中输出T,否则输出F。
输入样例:
5 4
46 23 26 24 10
24 is the root
26 and 23 are siblings
46 is the parent of 23
23 is a child of 10
输出样例:
F
T
F
T
分析:
STL中vector建立最大堆和最小堆相关知识
AC代码:
#include<stdio.h>
#include<string.h>
#include<vector>
#include<iostream>
#include<algorithm>
using namespace std;
vector<int>ve;
int Find(int x){return find(ve.begin()+1,ve.end(),x)-ve.begin();
}
int main(){ve.push_back(0);string s;int a,n,m;cin>>n>>m;for(int i=0;i<n;i++){cin>>a;ve.push_back(a);push_heap(ve.begin()+1,ve.end(),greater<int>());}while(m--){int a,b;cin>>a>>s;if(s=="and"){cin>>b>>s>>s;a = Find(a);b = Find(b);if(a/2 == b/2) printf("T\n");//兄弟结点else printf("F\n");}else{cin>>s>>s;if(s=="root"){if(ve[1] == a) printf("T\n");//如果是根结点else printf("F\n");}else if(s=="parent"){cin>>s>>b;a = Find(a);b = Find(b);if(a == b/2) printf("T\n");//a是b的父亲结点else printf("F\n");}else{cin>>s>>b;a = Find(a);b = Find(b);if(a/2 == b) printf("T\n");//a是b的儿子结点else printf("F\n");}}}return 0;
}