Description
输入一个整型数,判断是否是对称数,如果是,输出yes,否则输出no,不用考虑这个整型数过大,int类型存不下,不用考虑负值;
例如 12321是对称数,输出yes,124421是对称数,输出yes,1231不是对称数,输出no
Input
一个整型数
Output
输出是yes,或者no
Sample Input 1
12321
Sample Output 1
yes
Sample Input 2
1231
Sample Output 2
no
#include <bits/stdc++.h>
using namespace std;
typedef long long LL;
typedef pair<int, int> PII;
const int N = 1e5 + 10;
int a[N];void solve() {string s, p;cin >> s;p = s;reverse(p.begin(), p.end());if (s == p) {cout << "yes" << "\n";} else {cout << "no" << "\n";}}int main() {ios::sync_with_stdio(false);cin.tie(0); cout.tie(0);int _ = 1;
// cin >> _;while (_ -- ) {solve();}return 0;
}
一个偷鸡写法,直接读入字符串,然后把字符串倒转一下,再和原字符串比较。看是不是相等