15 华三华为链路聚合综述

1 链路聚合简介

以太网链路聚合通过将多条以太网物理链路捆绑在一起形成一条以太网逻辑链路,实现增加链路带宽的目的,同时这些捆绑在一起的链路通过相互动态备份,可以有效地提高链路的可靠性。

2 成员端口的状态

聚合组内的成员端口具有以下三种状态:

· 选中(Selected)状态:此状态下的成员端口可以参与数据的转发,处于此状态的成员端口称为“选中端口”。

· 非选中(Unselected)状态:此状态下的成员端口不能参与数据的转发,处于此状态的成员端口称为“非选中端口”。

· 独立(Individual)状态:此状态下的成员端口可以作为普通物理口参与数据的转发。满足以下条件时,如果成员端口在经过LACP(Link Aggregation Control Protocol,链路聚合控制协议)超时时间之后未收到LACP,则该成员端口会被置为该状态:

¡ 聚合接口配置为边缘端口。

¡ 处于选中/非选中状态的成员端口经过一次down、up后,该成员端口将被置为独立状态

链路聚合分为静态聚合和动态聚合两种模式,它们各自的优点如下所示:

· 静态聚合模式:一旦配置好后,端口的选中/非选中状态就不会受网络环境的影响,比较稳定。

· 动态聚合模式:通过LACP协议实现,能够根据对端和本端的信息调整端口的选中/非选中状态,比较灵活。

处于静态聚合模式下的聚合组称为静态聚合组,处于动态聚合模式下的聚合组称为动态聚合组。

4 配置设备ID

[SW-2024-0508]lacp  sy
[SW-2024-0508]lacp  system-m
[SW-2024-0508]lacp  system-mac ?
  H-H-H  MAC address

[SW-2024-0508]lacp  system-?
  system-mac       Specify the LACP system MAC address
  system-number    Specify the LACP system number
  system-priority  Specify system priority

[SW-2024-0508]lacp  system-pr
[SW-2024-0508]lacp  system-priority  ?
  INTEGER<0-65535>  System priority value

[SW-2024-0508]lacp  system-priority
[SW-2024-0508]interface  Bridge-Aggregation  ?
  <1-1024>  Bridge-Aggregation interface number

[SW-2024-0508]interface  Bridge-Aggregation  int
[SW-2024-0508]interface  Bridge-Aggregation  1
[SW-2024-0508-Bridge-Aggregation1]quit
[SW-2024-0508]int
[SW-2024-0508]interface  rou
[SW-2024-0508]interface  Route-Aggregation 2
[SW-2024-0508-Route-Aggregation2]quit

Arduino

5 配置二层静态链路聚合

#
interface Bridge-Aggregation34
#
interface NULL0
#
interface FortyGigE1/0/53
 port link-mode bridge
#
interface FortyGigE1/0/54
 port link-mode bridge
#
interface GigabitEthernet1/0/1
 port link-mode bridge
 combo enable fiber
#
interface GigabitEthernet1/0/2
 port link-mode bridge
 combo enable fiber
 port link-aggregation group 34
#
interface GigabitEthernet1/0/3
 port link-mode bridge
 combo enable fiber
 port link-aggregation group 34
#
interface GigabitEthernet1/0/4
 port link-mode bridge
 combo enable fiber
 port link-aggregation group 34
#

Arduino


[S5820-SW1]display  interface  Bridge-Aggregation 34
Bridge-Aggregation34
Current state: UP
IP packet frame type: Ethernet II, hardware address: 34eb-02c3-0100
Description: Bridge-Aggregation34 Interface
Bandwidth: 1000000 kbps
1Gbps-speed mode, full-duplex mode
Link speed type is autonegotiation, link duplex type is autonegotiation
PVID: 1
Port link-type: Access
 Tagged VLANs:   None
 Untagged VLANs: 1
Last clearing of counters: Never
 Last 300 second input:  0 packets/sec 0 bytes/sec 0%
 Last 300 second output:  0 packets/sec 0 bytes/sec 0%
 Input (total):  0 packets, 0 bytes
        0 unicasts, 0 broadcasts, 0 multicasts, 0 pauses
 Input (normal):  0 packets, 0 bytes
        0 unicasts, 0 broadcasts, 0 multicasts, 0 pauses
 Input:  0 input errors, 0 runts, 0 giants, 0 throttles
        0 CRC, 0 frame, 0 overruns, 0 aborts
        0 ignored, 0 parity errors
 Output (total): 0 packets, 0 bytes
        0 unicasts, 0 broadcasts, 0 multicasts, 0 pauses
 Output (normal): 0 packets, 0 bytes
        0 unicasts, 0 broadcasts, 0 multicasts, 0 pauses
 Output: 0 output errors, 0 underruns, 0 buffer failures
        0 aborts, 0 deferred, 0 collisions, 0 late collisions
        0 lost carrier, 0 no carrier

 

Arduino

[S5820-SW1]dis link-aggregation member-port  GigabitEthernet  1/0/3
Flags: A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,
       D -- Synchronization, E -- Collecting, F -- Distributing,
       G -- Defaulted, H -- Expired

GigabitEthernet1/0/3:
Aggregate Interface: Bridge-Aggregation34
Port Number: 4
Port Priority: 32768
Oper-Key: 1
[S5820-SW1]dis link-aggregation member-port  GigabitEthernet  1/0/4
Flags: A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,
       D -- Synchronization, E -- Collecting, F -- Distributing,
       G -- Defaulted, H -- Expired

GigabitEthernet1/0/4:
Aggregate Interface: Bridge-Aggregation34
Port Number: 5
Port Priority: 32768
Oper-Key: 1
[S5820-SW1]dis link-aggregation member-port  GigabitEthernet  1/0/1
The interface does not belong to any link aggregation group.
[S5820-SW1]dis link-aggregation member-port  GigabitEthernet  1/0/2
Flags: A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,
       D -- Synchronization, E -- Collecting, F -- Distributing,
       G -- Defaulted, H -- Expired

GigabitEthernet1/0/2:
Aggregate Interface: Bridge-Aggregation34
Port Number: 3
Port Priority: 32768
Oper-Key: 1
[S5820-SW1]

Arduino

[S5820-SW1]display  link-aggregation  summary
Aggregation Interface Type:
BAGG -- Bridge-Aggregation, BLAGG -- Blade-Aggregation, RAGG -- Route-Aggregation, SCH-B -- Schannel-Bundle
Aggregation Mode: S -- Static, D -- Dynamic
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Actor System ID: 0x8000, 34eb-02c3-0100

AGG        AGG   Partner ID              Selected  Unselected  Individual  Share
Interface  Mode                          Ports     Ports       Ports       Type
--------------------------------------------------------------------------------
BAGG34     S     None                    1         2           0           Shar
[S5820-SW1]

Arduino


[S5820-SW1]display  link-aggregation verbose
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Port: A -- Auto
Port Status: S -- Selected, U -- Unselected, I -- Individual
Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation,
        D -- Synchronization, E -- Collecting, F -- Distributing,
        G -- Defaulted, H -- Expired

Aggregate Interface: Bridge-Aggregation34
Aggregation Mode: Static
Loadsharing Type: Shar
  Port             Status  Priority Oper-Key
--------------------------------------------------------------------------------
  GE1/0/2          S       32768    1
  GE1/0/3          U       32768    1
  GE1/0/4          U       32768    1
[S5820-SW1

Arduino

[S5820-SW1]display  interface  Bridge-Aggregation  ?
  <34-34>  Bridge-Aggregation interface number
  >        Redirect it to a file
  >>       Redirect it to a file in append mode
  brief    Brief information of status and configuration for interface(s)
  |        Matching output
  <cr>

[S5820-SW1]display  interface  Bridge-Aggregation  b
[S5820-SW1]display  interface  Bridge-Aggregation  brief
Brief information on interfaces in bridge mode:
Link: ADM - administratively down; Stby - standby
Speed: (a) - auto
Duplex: (a)/A - auto; H - half; F - full
Type: A - access; T - trunk; H - hybrid
Interface            Link Speed   Duplex Type PVID Description
BAGG34               UP   3G(a)   F(a)   A    1

[S5820-SW1]dis
[S5820-SW1]display  li
[S5820-SW1]display  line
[S5820-SW1]display  link-aggregation s
[S5820-SW1]display  link-aggregation summary
Aggregation Interface Type:
BAGG -- Bridge-Aggregation, BLAGG -- Blade-Aggregation, RAGG -- Route-Aggregation, SCH-B -- Schannel-Bundle
Aggregation Mode: S -- Static, D -- Dynamic
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Actor System ID: 0x8000, 34eb-02c3-0100

AGG        AGG   Partner ID              Selected  Unselected  Individual  Share
Interface  Mode                          Ports     Ports       Ports       Type
--------------------------------------------------------------------------------
BAGG34     S     None                    3         0           0           Shar
[S5820-SW1]

Arduino

6 三层动态路由聚合配置

修改路由模式

<H3C>sys
System View: return to User View with Ctrl+Z.
[H3C]int
[H3C-GigabitEthernet1/0/2]port link-mode  route
[H3C-GigabitEthernet1/0/2]%May  9 22:09:18:900 2024 H3C IFNET/3                                                                     /PHY_UPDOWN: Physical state on the interface GigabitEthernet1/0                                                                     /2 changed to down.
%May  9 22:09:18:900 2024 H3C IFNET/5/LINK_UPDOWN: Line protoco                                                                     l state on the interface GigabitEthernet1/0/2 changed to down.

[H3C-GigabitEthernet1/0/2]q%May  9 22:09:20:942 2024 H3C IFNET/                                                                     3/PHY_UPDOWN: Physical state on the interface GigabitEthernet1/                                                                     0/2 changed to up.
%May  9 22:09:20:942 2024 H3C IFNET/5/LINK_UPDOWN: Line protoco                                                                     l state on the interface GigabitEthernet1/0/2 changed to up.
ui%May  9 22:09:22:202 2024 H3C LLDP/6/LLDP_CREATE_NEIGHBOR: Ne                                                                     arest bridge agent neighbor created on port GigabitEthernet1/0/                                                                     2 (IfIndex 3), neighbor's chassis ID is 36b8-9947-0100, port ID                                                                      is GigabitEthernet1/0/3.

[H3C-GigabitEthernet1/0/1]port link-mode  route
[H3C-GigabitEthernet1/0/1]%May  9 22:09:37:399 2024 H3C IFNET/3                                                                     /PHY_UPDOWN: Physical state on the interface GigabitEthernet1/0                                                                     /1 changed to down.
%May  9 22:09:37:399 2024 H3C IFNET/5/LINK_UPDOWN: Line protoco                                                                     l state on the interface GigabitEthernet1/0/1 changed to down.

[H3C-GigabitEthernet1/0/1]%May  9 22:09:39:437 2024 H3C IFNET/3                                                                     /PHY_UPDOWN: Physical state on the interface GigabitEthernet1/0                                                                     /1 changed to up.
%May  9 22:09:39:438 2024 H3C IFNET/5/LINK_UPDOWN: Line protoco                                                                     l state on the interface GigabitEthernet1/0/1 changed to up.

[H3C-GigabitEthernet1/0/1]qu%May  9 22:09:41:182 2024 H3C LLDP/                                                                     6/LLDP_CREATE_NEIGHBOR: Nearest bridge agent neighbor created o                                                                     n port GigabitEthernet1/0/1 (IfIndex 2), neighbor's chassis ID                                                                      is 36b8-9947-0100, port ID is GigabitEthernet1/0/2.

[H3C]interface  GigabitEthernet  11/0/4
                                 ^
 % Wrong parameter found at '^' position.
[H3C]interface  GigabitEthernet  1/0/4
[H3C-GigabitEthernet1/0/4]dis
[H3C-GigabitEthernet1/0/4]display  th
[H3C-GigabitEthernet1/0/4]display  this
#
interface GigabitEthernet1/0/4
 port link-mode bridge
 combo enable fiber
#
return
[H3C-GigabitEthernet1/0/4]port link-mode  route
[H3C-GigabitEthernet1/0/4]%May  9 22:10:04:954 2024 H3C IFNET/3                                                                     /PHY_UPDOWN: Physical state on the interface GigabitEthernet1/0                                                                     /4 changed to down.
%May  9 22:10:04:954 2024 H3C IFNET/5/LINK_UPDOWN: Line protoco                                                                     l state on the interface GigabitEthernet1/0/4 changed to down.

[H3C-GigabitEthernet1/0/4]%May  9 22:10:06:994 2024 H3C IFNET/3                                                                     /PHY_UPDOWN: Physical state on the interface GigabitEthernet1/0                                                                     /4 changed to up.
%May  9 22:10:06:994 2024 H3C IFNET/5/LINK_UPDOWN: Line protoco                                                                     l state on the interface GigabitEthernet1/0/4 changed to up.
dis
[H3C-GigabitEthernet1/0/4]display %May  9 22:10:08:169 2024 H3C                                                                      LLDP/6/LLDP_CREATE_NEIGHBOR: Nearest bridge agent neighbor cre                                                                     ated on port GigabitEthernet1/0/4 (IfIndex 5), neighbor's chass                                                                     is ID is 36b8-9947-0100, port ID is GigabitEthernet1/0/4.

 th
[H3C-GigabitEthernet1/0/4]display  this
#
interface GigabitEthernet1/0/4
 port link-mode route
 combo enable fiber
#
return
[H3C-GigabitEthernet1/0/4]

Arduino

三层聚合操作

[H3C]interface  ?
  Bridge-Aggregation   Bridge-Aggregation interface
  FortyGigE            FortyGigE interface
  GigabitEthernet      GigabitEthernet interface
  LoopBack             LoopBack interface
  M-GigabitEthernet    MGE interface
  NULL                 NULL interface
  Route-Aggregation    Route-Aggregation interface
  Ten-GigabitEthernet  Ten-GigabitEthernet interface
  Tunnel               Tunnel interface
  Tunnel-Bundle        Tunnel-Bundle interface
  Vlan-interface       VLAN interface
  range                Configure an interface range

[H3C]interface  ro
[H3C]interface  Route-Aggregation  12
[H3C-Route-Aggregation12]quit
[H3C]int
[H3C]interface  g
[H3C]interface  GigabitEthernet  1/0/1
[H3C-GigabitEthernet1/0/1]po
[H3C-GigabitEthernet1/0/1]por
[H3C-GigabitEthernet1/0/1]port li
[H3C-GigabitEthernet1/0/1]port link-r
[H3C-GigabitEthernet1/0/1]port link-?
  link-aggregation  Link aggregation group
  link-mode         Switch the specified interface to layer2 or layer3 ethernet

[H3C-GigabitEthernet1/0/1]port link-a
[H3C-GigabitEthernet1/0/1]port link-aggregation  ?
  group  Specify aggregation group number

[H3C-GigabitEthernet1/0/1]port link-aggregation  g
[H3C-GigabitEthernet1/0/1]port link-aggregation  group  12
[H3C-GigabitEthernet1/0/1]%May  9 22:12:46:431 2024 H3C IFNET/5/LINK_UPDOWN: Line protocol state on the interface GigabitEthernet1/0/1 changed to down.
%May  9 22:12:46:431 2024 H3C IFNET/3/IF_WARN: The jumboframe of the aggregate interface Route-Aggregation12 is not supported on the member port GigabitEthernet1/0/1
%May  9 22:12:46:432 2024 H3C LAGG/6/LAGG_ACTIVE: Member port GE1/0/1 of aggregation group RAGG12 changed to the active state.
%May  9 22:12:46:435 2024 H3C IFNET/5/LINK_UPDOWN: Line protocol state on the interface GigabitEthernet1/0/1 changed to up.
%May  9 22:12:46:435 2024 H3C IFNET/3/PHY_UPDOWN: Physical state on the interface Route-Aggregation12 changed to up.
%May  9 22:12:46:435 2024 H3C IFNET/5/LINK_UPDOWN: Line protocol state on the interface Route-Aggregation12 changed to up.

[H3C-GigabitEthernet1/0/1]dis
[H3C-GigabitEthernet1/0/1]display  th
[H3C-GigabitEthernet1/0/1]display  this
#
interface GigabitEthernet1/0/1
 port link-mode route
 combo enable fiber
 port link-aggregation group 12
#
return
[H3C-GigabitEthernet1/0/1]quit
[H3C]int
[H3C]interface  g
[H3C]interface  GigabitEthernet  1/0/2
[H3C-GigabitEthernet1/0/2]po
[H3C-GigabitEthernet1/0/2]port li
[H3C-GigabitEthernet1/0/2]port link-?
  link-aggregation  Link aggregation group
  link-mode         Switch the specified interface to layer2 or layer3 ethernet

[H3C-GigabitEthernet1/0/2]port link-a
[H3C-GigabitEthernet1/0/2]port link-aggregation  g
[H3C-GigabitEthernet1/0/2]port link-aggregation  group  ?
  INTEGER<1-1024>  Link aggregation group number

[H3C-GigabitEthernet1/0/2]port link-aggregation  group  12
[H3C-GigabitEthernet1/0/2]%May  9 22:13:23:496 2024 H3C IFNET/5/LINK_UPDOWN: Line protocol state on the interface GigabitEthernet1/0/2 changed to down.
%May  9 22:13:23:496 2024 H3C IFNET/3/IF_WARN: The jumboframe of the aggregate interface Route-Aggregation12 is not supported on the member port GigabitEthernet1/0/2
%May  9 22:13:23:496 2024 H3C LAGG/6/LAGG_ACTIVE: Member port GE1/0/2 of aggregation group RAGG12 changed to the active state.
%May  9 22:13:23:498 2024 H3C IFNET/5/LINK_UPDOWN: Line protocol state on the interface GigabitEthernet1/0/2 changed to up.

[H3C-GigabitEthernet1/0/2]dis
[H3C-GigabitEthernet1/0/2]display  th
[H3C-GigabitEthernet1/0/2]display  this
#
interface GigabitEthernet1/0/2
 port link-mode route
 combo enable fiber
 port link-aggregation group 12
#
return
[H3C-GigabitEthernet1/0/2]quit
[H3C]int
[H3C]interface  g
[H3C]interface  GigabitEthernet  1/0/4
[H3C-GigabitEthernet1/0/4]po
[H3C-GigabitEthernet1/0/4]port li
[H3C-GigabitEthernet1/0/4]port link-a
[H3C-GigabitEthernet1/0/4]port link-aggregation  g
[H3C-GigabitEthernet1/0/4]port link-aggregation  group  12
[H3C-GigabitEthernet1/0/4]%May  9 22:13:44:926 2024 H3C IFNET/5/LINK_UPDOWN: Line protocol state on the interface GigabitEthernet1/0/4 changed to down.
%May  9 22:13:44:926 2024 H3C IFNET/3/IF_WARN: The jumboframe of the aggregate interface Route-Aggregation12 is not supported on the member port GigabitEthernet1/0/4
%May  9 22:13:44:927 2024 H3C LAGG/6/LAGG_ACTIVE: Member port GE1/0/4 of aggregation group RAGG12 changed to the active state.
%May  9 22:13:44:929 2024 H3C IFNET/5/LINK_UPDOWN: Line protocol state on the interface GigabitEthernet1/0/4 changed to up.

[H3C-GigabitEthernet1/0/4]dis
[H3C-GigabitEthernet1/0/4]display  th
[H3C-GigabitEthernet1/0/4]display  this
#
interface GigabitEthernet1/0/4
 port link-mode route
 combo enable fiber
 port link-aggregation group 12
#
return
[H3C-GigabitEthernet1/0/4]

Arduino

测试

[H3C]display  interface  r
[H3C]display  interface  ro
[H3C]display  interface  Route-Aggregation  12
Route-Aggregation12
Current state: UP
Line protocol state: UP
Description: Route-Aggregation12 Interface
Bandwidth: 3000000 kbps
Maximum transmission unit: 1500
Internet protocol processing: Disabled
IP packet frame type: Ethernet II, hardware address: 36b8-9fd1-                                                                     0202
IPv6 packet frame type: Ethernet II, hardware address: 36b8-9fd                                                                     1-0202
Last clearing of counters: Never
 Last 300 second input rate: 0 bytes/sec, 0 bits/sec, 0 packets                                                                     /sec
 Last 300 second output rate: 0 bytes/sec, 0 bits/sec, 0 packet                                                                     s/sec
 Input: 0 packets, 0 bytes, 0 drops
 Output: 0 packets, 0 bytes, 0 drops

[H3C]dis
[H3C]display  int
[H3C]display  interface  rou
[H3C]display  interface  Route-Aggregation b
[H3C]display  interface  Route-Aggregation brief
Brief information on interfaces in route mode:
Link: ADM - administratively down; Stby - standby
Protocol: (s) - spoofing
Interface            Link Protocol Primary IP      Description                                                                      
RAGG12               UP   UP       --

[H3C]dis
[H3C]display  li
[H3C]display  li
[H3C]display li
[H3C]display line
[H3C]display link-aggregation s
[H3C]display link-aggregation summary
Aggregation Interface Type:
BAGG -- Bridge-Aggregation, BLAGG -- Blade-Aggregation, RAGG --                                                                      Route-Aggregation, SCH-B -- Schannel-Bundle
Aggregation Mode: S -- Static, D -- Dynamic
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Actor System ID: 0x8000, 36b8-9fd1-0200

AGG        AGG   Partner ID              Selected  Unselected                                                                       Individual  Share
Interface  Mode                          Ports     Ports                                                                            Ports       Type
---------------------------------------------------------------                                                                     -----------------
RAGG12     S     None                    3         0                                                                                0           Shar
[H3C]dis
[H3C]display  li
[H3C]display  line
[H3C]display  link-aggregation tr
[H3C]display  link-aggregation tr
[H3C]display  link-aggregation tr
[H3C]display  link-aggregation tr
[H3C]display  link-aggregation  ?
  load-sharing  Link aggregation load sharing
  member-port   Display member(s) of link aggregation group
  summary       Summary information
  verbose       Display verbose information of link aggregation                                                                      group

[H3C]display  link-aggregation  ver
[H3C]display  link-aggregation  verbose
Loadsharing Type: Shar -- Loadsharing, NonS -- Non-Loadsharing
Port: A -- Auto
Port Status: S -- Selected, U -- Unselected, I -- Individual
Flags:  A -- LACP_Activity, B -- LACP_Timeout, C -- Aggregation                                                                     ,
        D -- Synchronization, E -- Collecting, F -- Distributin                                                                     g,
        G -- Defaulted, H -- Expired

Aggregate Interface: Route-Aggregation12
Aggregation Mode: Static
Loadsharing Type: Shar
  Port             Status  Priority Oper-Key
---------------------------------------------------------------                                                                     -----------------
  GE1/0/1          S       32768    1
  GE1/0/2          S       32768    1
  GE1/0/4          S       32768    1
[H3C]dis
[H3C]display  li
[H3C]display  line
[H3C]display  link-aggregation br
[H3C]display  link-aggregation ?
  load-sharing  Link aggregation load sharing
  member-port   Display member(s) of link aggregation group
  summary       Summary information
  verbose       Display verbose information of link aggregation                                                                      group

[H3C]display  link-aggregation lo
[H3C]display  link-aggregation load-sharing
                                            ^
 % Incomplete command found at '^' position.
[H3C]display  link-aggregation g
[H3C]

Arduino

7 动态链路聚合

思路

1) 进入系统视图。

system-view

(2) 创建二层聚合接口,并进入二层聚合接口视图。

interface bridge-aggregation interface-number [ lite ]

创建二层聚合接口后,系统将自动生成同编号的二层聚合组,且该聚合组缺省工作在静态聚合模式下。

指定lite参数时,将创建精简型二层聚合接口;如果不指定lite参数,则创建普通二层聚合接口

(3) 配置聚合组工作在动态聚合模式下。

link-aggregation mode dynamic

缺省情况下,聚合组工作在静态聚合模式下。

(4) 退回系统视图。

quit

(5) 将二层以太网接口加入聚合组。

a. 进入二层以太网接口视图。

interface interface-type interface-number

b. 将二层以太网接口加入聚合组。

port link-aggregation group { group-id [ force ] | auto [ group-id ] }

多次执行此步骤可将多个二层以太网接口加入聚合组。

指定force参数时,会将聚合口上的属性配置同步给该接口。

指定auto参数时,会开启端口的半自动聚合功能。当配置半自动聚合后,建议用户不要修改自动创建的聚合组及其成员端口的配置,避免影响半自动聚合功能。

(6) 配置端口的LACP工作模式。

LACP(链路聚合控制协议)是一种基于IEEE 802.3ad标准的协议,它主要用于实现链路动态聚合,即将多条物理链路聚合成一条带宽更高的逻辑链路。

LACP模式主要有三种:

主动模式(Active Mode):在这种模式下,网络设备会主动发送LACP请求帧(LACPDU),并等待对端设备的回应。如果对端设备也支持LACP,并且配置为被动模式,则会回应LACPDU来建立链路聚合。

被动模式(Passive Mode):在这种模式下,网络设备只接收LACP请求帧,并根据请求进行相应的回应。被动模式的设备通常不主动发送LACPDU,而是等待对端设备在主动模式下发送请求来建立链路聚合。

静态模式(Static Mode):这是一种不依赖于LACP协议的链路聚合方式。在静态模式下,管理员手动配置链路聚合,而不需要LACP协议的握手过程。静态模式适用于一些不支持LACP的设备,或者在特定情况下需要避免LACP协议的使用。

在你的问题中,lacp mode passive指的是将LACP协议设置为被动模式。在这种模式下,设备不会主动发送LACP请求帧,而是等待对端设备的LACP请求帧来进行回应和链路聚合。

¡ 配置端口的LACP工作模式为PASSIVE。

lacp mode passive

¡ 配置端口的LACP工作模式为ACTIVE。

undo lacp mode

缺省情况下,端口的LACP工作模式为ACTIVE。

(7) (可选)配置端口优先级。

link-aggregation port-priority priority

缺省情况下,端口优先级为32768。

(8) (可选)配置端口的LACP超时时间为短超时(3秒)。

lacp period short

缺省情况下,端口的LACP超时时间为长超时(90秒)。

请不要在ISSU升级前配置LACP超时时间为短超时,否则在ISSU升级期间会出现网络流量中断。有关ISSU升级的详细介绍请参见“基础配置指导”中的“ISSU配置”。

8  二层动态链路聚合

#
 sysname SW2-51890
#
interface Bridge-Aggregation234
 link-aggregation mode dynamic
#
interface GigabitEthernet1/0/5
 port link-mode bridge
 combo enable fiber
 shutdown
 link-aggregation port-priority 100
 lacp mode passive
 port link-aggregation group 234
#
interface GigabitEthernet1/0/6
 port link-mode bridge
 combo enable fiber
 link-aggregation port-priority 100
 lacp mode passive
 port link-aggregation group 234
#
interface GigabitEthernet1/0/7
 port link-mode bridge
 combo enable fiber
 shutdown
 link-aggregation port-priority 100
 lacp mode passive
 port link-aggregation group 234

Arduino

interface Bridge-Aggregation234:定义了一个名为"Bridge-Aggregation234"的逻辑链路聚合接口。

link-aggregation mode dynamic:设置链路聚合模式为动态,意味着链路聚合可以自动建立。

interface GigabitEthernet1/0/5interface GigabitEthernet1/0/6interface GigabitEthernet1/0/7:分别是三个不同的千兆以太网接口配置。

port link-mode bridge:设置端口的工作模式为桥接模式,这通常用于交换机或路由器上的端口,使其可以作为网络交换的一部分。

combo enable fiber:启用combo端口,允许使用光纤或铜缆,具体取决于插入的模块。

shutdown:关闭接口,使其不活动。

link-aggregation port-priority 100:设置链路聚合的端口优先级为100,这可能用于链路聚合控制,如故障转移。

lacp mode passive:设置LACP(链路聚合控制协议)的工作模式为被动,意味着接口将不会主动尝试建立链路聚合,但会响应其他接口的聚合请求。

port link-aggregation group 234:将这些端口加入到编号为234的链路聚合组中。

9 三层动态链路聚合

[SW1-5128]interface  range GigabitEthernet  1/0/5 to GigabitEthernet 1/0/7
[SW1-5128-if-range]port link-mode  route
[SW1-5128-if-range]

Arduino

[SW1-5128]interface range GigabitEthernet 1/0/5 to GigabitEthernet 1/0/7:这个命令开始一个接口范围的配置,涵盖了从GigabitEthernet 1/0/5到GigabitEthernet 1/0/7的所有接口。

[SW1-5128-if-range]port link-mode route:这个命令将接口的链路模式设置为“route”。在网络设备上,通常有两种链路模式:桥接模式(bridge)和路由模式(route)。路由模式通常用于路由器接口,允许设备对通过该接口的流量进行路由选择。

[SW1-5128]interface  Route-Aggregation ?
  <1-1024>  Route-Aggregation interface number

[SW1-5128]interface  Route-Aggregation 123
[SW1-5128-Route-Aggregation123]link-aggregation
[SW1-5128-Route-Aggregation123]link-aggregation  ?
  load-sharing   Link aggregation load sharing
  mode           Specify mode of the link aggregation group
  selected-port  Specify Selected ports
[SW1-5128-Route-Aggregation123]link-aggregation  mode  dynamic
[SW1-5128-Route-Aggregation123]

Arduino

[SW1-5128]interface Route-Aggregation ?:这个命令尝试进入一个名为“Route-Aggregation”的接口配置模式,并询问可用的接口编号。

<1-1024>:这表示您可以输入一个介于1到1024之间的数字来选择一个特定的聚合接口编号。

[SW1-5128]interface Route-Aggregation 123:这个命令尝试选择编号为123的聚合接口进行配置。

[SW1-5128-Route-Aggregation123]link-aggregation:这个命令进入链路聚合配置模式。

[SW1-5128-Route-Aggregation123]link-aggregation ?:这个命令列出了链路聚合配置的可用选项。

load-sharing:这个选项可能用于配置链路聚合的负载共享方式。

mode:这个选项用于指定链路聚合组的工作模式。

selected-port:这个选项可能用于指定哪些端口将被包含在链路聚合中。

[SW1-5128-Route-Aggregation123]link-aggregation mode dynamic:这个命令将链路聚合的模式设置为动态,意味着链路聚合可以自动建立。

[SW1-5128]interface  range GigabitEthernet  1/0/5 to GigabitEthernet  1/0/7
[SW1-5128-if-range]link-aggregation  port-priority  123
[SW1-5128-if-range]lacp  mode  ?
  passive  Enable LACP only if the interface receives LACPDUs from the opposite
           device
[SW1-5128-if-range]lacp  mode  passive
[SW1-5128-if-range]port link-aggregation ?
  group  Specify aggregation group number
[SW1-5128-if-range]port link-aggregation group  123

Arduino

[SW1-5128]interface range GigabitEthernet 1/0/5 to GigabitEthernet 1/0/7:这个命令开始配置一系列接口,从GigabitEthernet 1/0/5到GigabitEthernet 1/0/7。

[SW1-5128-if-range]link-aggregation port-priority 123:这个命令为链路聚合设置端口优先级为123。端口优先级通常用于决定链路聚合的控制路径,当有多个端口可以成为聚合的一部分时。

[SW1-5128-if-range]lacp mode ?:这个命令列出了LACP(链路聚合控制协议)的可用模式。

passive:这是列出的一个模式选项,表示接口将处于被动模式,意味着它将响应其他设备的LACP请求,但不会主动发送LACP请求。

[SW1-5128-if-range]lacp mode passive:这个命令将链路聚合的模式设置为被动。

[SW1-5128-if-range]port link-aggregation ?:这个命令列出了端口链路聚合的可用配置选项。

group:这是列出的一个选项,用于指定端口应该属于哪个链路聚合组。

[SW1-5128-if-range]port link-aggregation group 123:这个命令将当前配置的接口范围(GigabitEthernet 1/0/5到GigabitEthernet 1/0/7)分配到编号为123的链路聚合组。

10 华为Eth-Trunk(链路聚合)

1、Eth-Trunk(链路聚合技术 )

1)eth-trunk可以把多个独立的物理接口绑定在一起,作为一个大带宽的逻辑接口使用。

2、Eth-Trunk优势:

1)增加设备之间的互联带宽

2)提高设备之间的可靠性

3)对流量负载均衡,提高链路利用率

3、Eth-Trunk链路聚合模式

1)手工模式

2)LACP模式

4、手工模式:如下图

1)手工模式下3条活动链路都参与数据转发并分担流量

2)当一条链路故障时,在剩余的2条活动链路中分担流量

5、Eth-Trunk接口配置流程

1)创建eth-trunk

2)选择链路聚合模式

3)在eth-trunk中加入成员接口

6、配置手工模式Eth-trunk

拓扑

需求

1)对交换机之间的链路进行链路捆绑,增加互联带宽

2)确保同 VLAN的 PC 之间互通

配置步骤

1)PC配置IP地址

2)所有交换机创建vlan10 和vlan20

3)交换机和PC互联的接口设置为access ,并加入指定的vlan

4)创建Eth-Trunk

5)配置Eth-Trunk的工作模式为手工模式

6)Eth-Trunk中加入成员接口

配置命令

**SW1配置:**
[SW1]vlan batch 10 20   
[SW1]interface G0/0/3 
[SW1-G0/0/3]port link-type access    
[SW1-G0/0/3]port default vlan 10 
 
[SW1-G0/0/3]interface G0/0/4
[SW1-G0/0/4]port link-type access    
[SW1-G0/0/4]port default vlan 20  
[SW1-G0/0/4]quit

[SW1]interface eth-trunk 1   //创建并进入 eth-trunk 1
[SW1-Eth-Trunk1]mode manual load-balance   //配置手工模式
[SW1-Eth-Trunk1]trunkport g0/0/1   //加入成员端口
[SW1-Eth-Trunk1]trunkport g0/0/2   //加入成员端口
[SW1-Eth-Trunk1]port link-type trunk      //配置 eth-trunk 类型为 trunk
[SW1-Eth-Trunk1]port trunk allow-pass vlan 10 20   //允许 vlan10和vlan20

**SW2配置:**
[SW2]vlan batch 10 20   
[SW2]interface G0/0/3 
[SW2-G0/0/3]port link-type access    
[SW2-G0/0/3]port default vlan 10  
[SW2-G0/0/3]interface G0/0/4
[SW2-G0/0/4]port link-type access    
[SW2-G0/0/4]port default vlan 20  

[SW2]interface eth-trunk 1
[SW2-Eth-Trunk1]mode manual load-balance
[SW2-Eth-Trunk1]trunkport g0/0/1
[SW2-Eth-Trunk1]trunkport g0/0/2
[SW2-Eth-Trunk1]port link-type trunk     
[SW2-Eth-Trunk1]port trunk allow-pass vlan 10 20  

验证与测试:
pc1 ping pc3  通
pc2 ping pc4  通

Haskell

7、LACP模式:如下图:

1)LACP模式也称为M:N模式

2)M条活动链路,N条备份链路

3)当活动链路出现故障时,备份链路才进行转发

8、LACP模式工作原理

确定主动端

确定活动链路

LACP抢占功能

9、确定LACP主动端

1)通过比较两端交换机的系统优先级来确定LACP主动端

2)系统优先级数值越小越优先,默认值是32768

3)如果系统优先级相同,则比较两端设备的MAC地址,越小越优先

10、确定LACP活动链路

1)通过系统优先级选举出LACP主动端后,以主动端的接口优先级来选择活动接口

2)接口优先级数值越小越优先,默认值是32768

3)如果主动端设备的接口优先级相同,则根据接口号的大小来选举活动端口,(接口号越小越优先)

11、配置LACP模式Eth-trunk

拓扑
需求

-PC1和PC3属于vlan 10、PC2和PC4属于vlan 20

-设备之间配置lacp模式的链路聚合,并确保同vlan之间的主机可以互通

配置步骤

1)PC配置IP地址

2)所有的交换机都创建vlan10 20

3) 交换机和pc互联的接口做成access ,并且加入指定的vlan

4)设置交换机的lacp 优先级,确定主动端设备

5) 配置链路聚合

-创建链路聚合组,组号为1

-配置链路聚合的工作模式lacp

-在链路聚合中添加成员接口

-设置接口trunk模式

-设置活动端口(活动链路)的上限阈值为2

-开启lacp 抢占

配置命令

**SW1配置:**
[SW1]vlan batch 10 20
[SW1]int g0/0/4
[SW1-GigabitEthernet0/0/4]port link-type access
[SW1-GigabitEthernet0/0/4]port default vlan 10
[SW1-GigabitEthernet0/0/4]int g0/0/5
[SW1-GigabitEthernet0/0/5]port link-type access
[SW1-GigabitEthernet0/0/5]port default vlan 20
[SW1-GigabitEthernet0/0/5]quit

[SW1]lacp priority 100    //配置lacp的系统优先级(越小越优先)
[SW1]interface eth-trunk 1   //创建链路聚合组1
[SW1-Eth-Trunk1]mode lacp-static   //链路聚合的工作模式是lacp
[SW1-Eth-Trunk1]trunkport  g 0/0/1  to  0/0/3   //在链路聚合组中添加成员接口
[SW1-Eth-Trunk1]port link-type trunk     //设置trunk模式
[SW1-Eth-Trunk1]port trunk allow-pass vlan 10 20    //允许vlan10 20 流量通过
[SW1-Eth-Trunk1]max active-linknumber 2   //设置活动端口的上限阈值为2  
[SW1-Eth-Trunk1]lacp preempt enable   //开启抢占功能

**SW2配置:**
[SW2]vlan batch  10  20
[SW2]int g0/0/4
[SW2-GigabitEthernet0/0/4]port link-type access
[SW2-GigabitEthernet0/0/4]port default vlan 10
[SW2-GigabitEthernet0/0/4]int g0/0/5
[SW2-GigabitEthernet0/0/5]port link-type access
[SW2-GigabitEthernet0/0/5]port default vlan 20
[SW2-GigabitEthernet0/0/5]quit
[SW2]int eth-trunk 1
[SW2-Eth-Trunk1]mode lacp-static
[SW2-Eth-Trunk1]trunkport g 0/0/1 to 0/0/3
[SW2-Eth-Trunk1]max active-linknumber 2
[SW2-Eth-Trunk1]port link-type trunk
[SW2-Eth-Trunk1]port trunk allow-pass vlan 10 20
[SW2-Eth-Trunk1]lacp preempt enable

**测试与验证:**
pc1 ping  pc3  通
pc1 ping  pc4  通

[SW1]display eth-trunk 1    //显示链路聚合信息                     
Preempt Delay Time: 30     //抢占延迟30秒        
System Priority: 100     //系统优先级:100                  
Least Active-linknumber: 1  Max Active-linknumber: 2 (最大活跃链路:2)                         
Operate status: up  (状态:up)                  
--------------------------------------------------------------------------------
ActorPortName          Status   PortType PortPri  PortNo
GigabitEthernet0/0/1   Selected 1GE      32768    2  (lacp给本段接口分配的序号)
GigabitEthernet0/0/2   Selected 1GE      32768    3     
GigabitEthernet0/0/3   Unselect 1GE      32768    4
 
 备注:  Selected :被选择的接口      
       Unselect :位被选择的接口
       PortPri : 端口lacp优先级
       PortNo  : lacp 协议给成员口分配的编号

Partner: (本段接口所连接的对端设备接口信息)
--------------------------------------------------------------------------------
ActorPortName          SysPri   SystemID        PortPri  **PortNo**
GigabitEthernet0/0/1   32768    4c1f-ccef-5a42  32768    4 (lacp给对端接口分配的序号)
GigabitEthernet0/0/2   32768    4c1f-ccef-5a42  32768    5 
GigabitEthernet0/0/3   32768    4c1f-ccef-5a42  32768    6

Haskell

链路聚合综合实验

[S1]interface Eth-Trunk 1

[SW1-Eth-Trunk1]mode lacp-static

[S1-Eth-Trunk1]trunkportGigabitEthernet 0/0/3 0/0/4

[S1-Eth-Trunk1]port link-typetrunk

[S1-Eth-Trunk1]port trunk allow-pass vlan all

[S2]interface Eth-Trunk 1

[SW2-Eth-Trunk1]mode lacp-static

[S2-Eth-Trunk1]trunkportGigabitEthernet 0/0/5 0/0/6

[S2-Eth-Trunk1]port link-typetrunk

[S2-Eth-Trunk1]port trunk allow-pass vlan ALL

[S3]interface Eth-Trunk 1

[SW3-Eth-Trunk1]mode lacp-static

[S3-Eth-Trunk1]trunkportGigabitEthernet 0/0/3 0/0/4

[S3-Eth-Trunk1]port link-typetrunk

[S3-Eth-Trunk1]port trunk allow-pass vlan all

[S4]interface Eth-Trunk 1

[SW4-Eth-Trunk1]mode lacp-static

[S4-Eth-Trunk1]trunkportGigabitEthernet 0/0/5 0/0/6

[S4-Eth-Trunk1]port link-typetrunk

[S4-Eth-Trunk1]port trunk allow-pass vlan all

[S5]interface Eth-Trunk 1

[SW5-Eth-Trunk1]mode lacp-static

[S5-Eth-Trunk1]trunkportGigabitEthernet 0/0/3 0/0/4

[S5-Eth-Trunk1]port link-typetrunk

[S5-Eth-Trunk1]port trunkallow-pass vlan all

[S5]interface Eth-Trunk 2

[SW5-Eth-Trunk2]mode lacp-static

[S5-Eth-Trunk2]trunkportGigabitEthernet 0/0/5 0/0/6

[S5-Eth-Trunk2]port link-typetrunk

[S5-Eth-Trunk2]port trunkallow-pass vlan all

[S5]interface Eth-Trunk 3

[SW5-Eth-Trunk3]mode lacp-static

[S5-Eth-Trunk3]trunkportGigabitEthernet 0/0/7 0/0/8

[S5-Eth-Trunk3]port link-typetrunk

[S5-Eth-Trunk3]port trunkallow-pass vlan all

[S6]interface Eth-Trunk 1

[SW6-Eth-Trunk1]mode lacp-static

[S6-Eth-Trunk1]trunkportGigabitEthernet 0/0/5 0/0/6

[S6-Eth-Trunk1]port link-typetrunk

[S6-Eth-Trunk1]port trunkallow-pass vlan all

[S6]interface Eth-Trunk 2

[SW6-Eth-Trunk2]mode lacp-static

[S6-Eth-Trunk2]trunkportGigabitEthernet 0/0/3 0/0/4

[S6-Eth-Trunk2]port link-typetrunk

[S6-Eth-Trunk2]port trunkallow-pass vlan all

[S6]interface Eth-Trunk 3

[SW6-Eth-Trunk3]mode lacp-static

[S6-Eth-Trunk3]trunkportGigabitEthernet 0/0/7 0/0/8

[S6-Eth-Trunk3]port link-typetrunk

[S6-Eth-Trunk3]port trunk allow-pass vlan all

Haskell

2)S1-S6创建vlan

[S1]vlan batch 10 20

[S2]vlan batch 10 20

[S3]vlan batch 10 20

[S4]vlan batch 10 20

[S5]vlan batch 10 20

[S6]vlan batch 10 20

Haskell

3)S1-S4端口加入vlan

[S1]interface GigabitEthernet0/0/1

[S1-GigabitEthernet0/0/1]portlink-type access

[S1-GigabitEthernet0/0/1]port default vlan 10

[S2]interface GigabitEthernet0/0/1

[S2-GigabitEthernet0/0/1]portlink-type access

[S2-GigabitEthernet0/0/1]port default vlan 20

[S3]interface GigabitEthernet0/0/1

[S3-GigabitEthernet0/0/1]portlink-type access

[S3-GigabitEthernet0/0/1]port default vlan 10

[S4]interface GigabitEthernet0/0/1

[S4-GigabitEthernet0/0/1]portlink-type access

[S4-GigabitEthernet0/0/1]port default vlan 20

Haskell

11华为设备的静态链路聚合

[Huawei]interface  Eth-Trunk  3
[Huawei-Eth-Trunk3]mo  
[Huawei-Eth-Trunk3]mode  m  
[Huawei-Eth-Trunk3]mode  manual  ?
  load-balance  Load balance working mode

[Huawei-Eth-Trunk3]mode ?
  lacp-static  Static working mode
  manual       Manual working mode

[Huawei-Eth-Trunk3]mode
                        ^
Error:Incomplete command found at '^' position.
[Huawei-Eth-Trunk3]quit
[Huawei]interface Eth-Trunk 3
[Huawei-Eth-Trunk3]tr  
[Huawei-Eth-Trunk3]trunkport ?
  GigabitEthernet  GigabitEthernet interface

[Huawei-Eth-Trunk3]trunkport g  
[Huawei-Eth-Trunk3]trunkport GigabitEthernet  ?
  <0-0>  Slot number

[Huawei-Eth-Trunk3]trunkport GigabitEthernet  

[SW1-Eth-Trunk1]port link-type trunk     //设置trunk模式
[SW1-Eth-Trunk1]port trunk allow-pass vlan 10 20    //允许vlan10 20 流量通过
[SW1-Eth-Trunk1]max active-linknumber 2   //设置活动端口的上限阈值为2  
[SW1-Eth-Trunk1]lacp preempt enable   //开启抢占功能

Haskell

您提供的文本是华为设备上链路聚合(Eth-Trunk)的配置示例。以下是对这些命令的解释:

[Huawei]interface Eth-Trunk 3:进入华为设备上的逻辑链路聚合接口3的配置模式。

[Huawei-Eth-Trunk3]mo:这个命令不完整,可能是想要输入mode来设置链路聚合的工作模式。

[Huawei-Eth-Trunk3]mode m:这个命令同样不完整,应该是想要指定链路聚合的工作模式,但具体模式未指定。

[Huawei-Eth-Trunk3]mode manual:设置链路聚合为手动模式,这意味着端口是被手动添加到聚合组中,而不是通过协议自动发现。

[Huawei-Eth-Trunk3]mode ?:列出了可用的链路聚合模式。

lacp-static:静态模式,通常用于LACP(链路聚合控制协议)。

manual:手动模式,端口需要手动配置为聚合的一部分。

Error:Incomplete command found at '^' position.:命令不完整,提示错误。

[Huawei-Eth-Trunk3]quit:退出当前配置模式。

[Huawei]interface Eth-Trunk 3:重新进入Eth-Trunk 3的配置模式。

[Huawei-Eth-Trunk3]tr:这个命令不完整,可能是想要输入trunkport来设置链路聚合的成员端口。

[Huawei-Eth-Trunk3]trunkport ?:列出了添加端口到链路聚合的可用选项。

GigabitEthernet:提示输入GigabitEthernet接口。

[Huawei-Eth-Trunk3]trunkport GigabitEthernet ?:提示输入具体的GigabitEthernet接口编号。

<0-0>:提示输入插槽编号。

[SW1-Eth-Trunk1]port link-type trunk:在另一个设备上,设置端口链路类型为trunk模式。

[SW1-Eth-Trunk1]port trunk allow-pass vlan 10 20:配置trunk端口允许VLAN 10和VLAN 20的流量通过。

[SW1-Eth-Trunk1]max active-linknumber 2:设置链路聚合中活动端口的最大数量为2。

[SW1-Eth-Trunk1]lacp preempt enable:启用LACP抢占功能,允许该设备在LACP协商中作为主导设备。

请注意,这些命令需要根据实际的网络环境和需求进行调整。链路聚合的配置需要确保两端的设备都支持相应的协议,并且配置一致。此外,VLAN的配置也需要确保网络中其他设备允许相应的VLAN流量通过。

12 华为设备的动态链路聚合

[Huawei]lacp  priority  100
<Huawei>u t m
Info: Current terminal monitor is off.
[Huawei]interface  Eth-Trunk  34
[Huawei-Eth-Trunk34]mode  lacp-static

[Huawei-Eth-Trunk34]trunkport GigabitEthernet  0/0/1
Info: This operation may take a few seconds. Please wait for a moment...done.
[Huawei-Eth-Trunk34]trunkport GigabitEthernet 0/0/2
Info: This operation may take a few seconds. Please wait for a moment...done.
[Huawei-Eth-Trunk34]trunkport GigabitEthernet 0/0/5
Info: This operation may take a few seconds. Please wait for a moment...done.
[Huawei-Eth-Trunk34]max ?
  active-linknumber              Max active linknumber in link aggregation
                                 group
  bandwidth-affected-linknumber  The maximum number of the affect-bandwidth
                                 links

[Huawei-Eth-Trunk34]max active-linknumber  3
[Huawei-Eth-Trunk34]lacp  preempt  ?
  delay   Delay time of preemption
  enable  Enable preemption
[Huawei-Eth-Trunk34]lacp  preempt  enable
[Huawei-Eth-Trunk34]display  eth-trunk  34
Eth-Trunk34's state information is:
Local:
LAG ID: 34                  WorkingMode: STATIC                               
Preempt Delay Time: 30      Hash arithmetic: According to SIP-XOR-DIP         
System Priority: 100        System ID: 4c1f-cc0e-4cd0                         
Least Active-linknumber: 1  Max Active-linknumber: 3                          
Operate status: up          Number Of Up Port In Trunk: 3                     
--------------------------------------------------------------------------------
ActorPortName          Status   PortType PortPri PortNo PortKey PortState Weight
GigabitEthernet0/0/1   Selected 1GE      32768   2      8753    10111100  1     
GigabitEthernet0/0/2   Selected 1GE      32768   3      8753    10111100  1     
GigabitEthernet0/0/4   Selected 1GE      32768   5      8753    10111100  1     
GigabitEthernet0/0/5   Unselect 1GE      32768   6      8753    10100000  1     

Partner:
--------------------------------------------------------------------------------
ActorPortName          SysPri   SystemID        PortPri PortNo PortKey PortState
GigabitEthernet0/0/1   32768    4c1f-cc56-3336  32768   2      8753    10111100
GigabitEthernet0/0/2   32768    4c1f-cc56-3336  32768   3      8753    10111100
GigabitEthernet0/0/4   32768    4c1f-cc56-3336  32768   5      8753    10111100
GigabitEthernet0/0/5   32768    4c1f-cc56-3336  32768   6      8753    10100000

Haskell

[Huawei]lacp priority 100:设置链路聚合控制协议(LACP)的系统优先级为100。优先级较高的设备在聚合过程中将扮演更主导的角色。

<Huawei>u t m:这个命令的意图不明确,可能是一个错误的输入或不完整的命令。

Info: Current terminal monitor is off.:提示当前终端监控已关闭。

[Huawei]interface Eth-Trunk 34:进入逻辑链路聚合接口34的配置模式。

[Huawei-Eth-Trunk34]mode lacp-static:设置链路聚合的工作模式为静态LACP模式。

[Huawei-Eth-Trunk34]trunkport GigabitEthernet 0/0/1[Huawei-Eth-Trunk34]trunkport GigabitEthernet 0/0/2[Huawei-Eth-Trunk34]trunkport GigabitEthernet 0/0/5:将GigabitEthernet 0/0/1、0/0/2和0/0/5端口添加到Eth-Trunk 34中。

[Huawei-Eth-Trunk34]max active-linknumber 3:设置链路聚合中活动端口的最大数量为3。

[Huawei-Eth-Trunk34]lacp preempt enable:启用LACP抢占功能,允许该设备在LACP协商中快速成为主导设备。

[Huawei-Eth-Trunk34]display eth-trunk 34:显示Eth-Trunk 34的状态信息。

显示的输出信息提供了Eth-Trunk 34的详细信息:

LAG ID:链路聚合组的ID,这里是34。

WorkingMode:工作模式,这里是STATIC,表示静态LACP模式。

Preempt Delay Time:抢占延迟时间,这里是30秒。

Hash arithmetic:哈希算法,这里是根据源IP地址(SIP)、目标IP地址(DIP)和端口号进行的XOR运算。

System Priority:系统优先级,这里是100。

System ID:系统ID,用于区分不同的设备。

Least Active-linknumber:链路聚合中最少活动链路数量,这里是1。

Max Active-linknumber:链路聚合中最大活动链路数量,这里是3。

Operate status:操作状态,这里是up,表示链路聚合是激活的。

Number Of Up Port In Trunk:链路聚合中激活端口的数量,这里是3。

12  华三链路聚合的维护

详细作用

查询命令

显示聚合接口的相关信息

display interface [ { bridge-aggregation | route-aggregation } [ interface-number ] ] [ brief [ description | down ] ]

显示本端系统的设备ID

display lacp system-id

显示全局或聚合组内采用的聚合负载分担类型

display link-aggregation load-sharing mode[ interface [ { bridge-aggregation | route-aggregation } interface-number ] ]

显示成员端口上链路聚合的详细信息

display link-aggregation member-port [ interface-list | auto ]

显示所有聚合组的摘要信息

display link-aggregation summary

显示聚合组成员端口的选中状态及原因

display link-aggregation troubleshooting [ { bridge-aggregation | route-aggregation } [ interface-number  ] ]

显示已有聚合接口所对应聚合组的详细信息

display link-aggregation verbose [ { bridge-aggregation | route-aggregation } [ interface-number ] ] [ all-configuration ]

清除聚合接口上的统计信息

reset counters interface [ { bridge-aggregation | route-aggregation } [ interface-number ] ]

清除成员端口上的LACP统计信息

reset lacp statistics [ interface interface-list ]

S300, S500, S2700, S5700, S6700 产品文档 (huawei.com)

本文来自互联网用户投稿,该文观点仅代表作者本人,不代表本站立场。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如若转载,请注明出处:http://www.mzph.cn/pingmian/9742.shtml

如若内容造成侵权/违法违规/事实不符,请联系多彩编程网进行投诉反馈email:809451989@qq.com,一经查实,立即删除!

相关文章

Ps 滤镜:视频

Ps菜单&#xff1a;滤镜/视频 Filter/Video “视频”滤镜子菜单中包含了“NTSC 颜色”和“逐行”两个滤镜。 这两个滤镜都是针对视频和电视播放的特定需求设计的。 “逐行”滤镜主要解决交错视频的视觉问题&#xff0c;而“NTSC 颜色”滤镜则确保色彩在电视播放时的兼容性和准确…

Java设计模式 _结构型模式_享元模式

一、享元模式 1、享元模式 享元模式&#xff08;Flyweight Pattern&#xff09;是一种结构型模式。主要用于减少创建对象的数量&#xff0c;以减少内存占用和提高性能。主要解决有大量对象时&#xff0c;有可能会造成内存溢出&#xff0c;我们把其中共同的部分抽象出来&#x…

django中的日志处理

1、事件追踪 在什么样的时间发生了什么样的事情 2、bug调试 3、程序告警 4、大数据统计 ELK 日志分析系统 elasticsearh logstasn kibana 名词概念 loggers&#xff1a;日志器 —— 定大方向&#xff1a;1 handlers&#xff1a;处理器 —— 执行:3 formatters&#xff…

【C++】详细版 RAII技术的应用之智能指针(智能指针发展历程和简单模拟实现介绍)

目录 前言 一、智能指针有什么用&#xff1f; 二、什么是RAII(智能指针的底层思想)&#xff1f; 三、智能指针的发展历程以及模拟实现 1.auto_ptr&#xff08;C98&#xff09; 2.unique_ptr&#xff08;C11&#xff09; 3.shared_ptr&#xff08;C11&#xff09; 前言 C中…

【vulhub靶场】Apache 中间件漏洞复现

【vulhub靶场】Apache 中间件漏洞复现 一、Apache HTTPD 换行解析漏洞&#xff08;CVE-2017-15715&#xff09;1. 漏洞详情2. 影响版本3. 漏洞复现 二、Apache多后缀解析漏洞&#xff08;apache_parsing_vulnerability&#xff09;1. 漏洞详情2. 漏洞复现 三、Apache HTTP Serv…

【Python爬虫实战入门】:教你一个程序实现PPT模版自由

文章目录 &#x1f4a5;一、PPT模版爬取&#x1f525;1.1 第一个爬虫&#x1f6b2;1. 获取下载页面链接 ❤️1.2 第二个爬虫&#x1f6b2;1.3 第三个爬虫&#x1f388;2. 文件保存 ❤️1.4 翻页处理 &#x1f525;二、完整代码 &#x1f525;&#x1f525;&#x1f525; Pytho…

【Linux】简易进度条的实现

&#x1f389;博主首页&#xff1a; 有趣的中国人 &#x1f389;专栏首页&#xff1a; Linux &#x1f389;其它专栏&#xff1a; C初阶 | C进阶 | 初阶数据结构 小伙伴们大家好&#xff0c;本片文章将会讲解Linux中进度条的实现的相关内容。 如果看到最后您觉得这篇文章写得…

深度学习论文: LightGlue: Local Feature Matching at Light Speed

深度学习论文: LightGlue: Local Feature Matching at Light Speed LightGlue: Local Feature Matching at Light Speed PDF: https://arxiv.org/pdf/2306.13643 PyTorch代码: https://github.com/shanglianlm0525/CvPytorch PyTorch代码: https://github.com/shanglianlm0525/…

AI算法-高数2-导数定义和公式

P14 2.1 导数的定义(一):2.1 导数的定义_哔哩哔哩_bilibili 导数定义&#xff1a; 导数公式&#xff1a; P15 2.1 导数的定义(二)&#xff1a;2.1 导数的定义&#xff08;二&#xff09;_哔哩哔哩_bilibili [a,b]可导&#xff0c;a的端点&#xff1a;右可导&#xff0c;b端点&…

Leetcode—138. 随机链表的复制【中等】(cend函数)

2024每日刷题&#xff08;129&#xff09; Leetcode—138. 随机链表的复制 实现代码 /* // Definition for a Node. class Node { public:int val;Node* next;Node* random;Node(int _val) {val _val;next NULL;random NULL;} }; */class Solution { public:Node* copyRan…

Spring JdbcTemplate使用临时表+事务会话管理实现数据新增、查询及自动清除功能

需求描述&#xff1a; 由于某些情况下当查询过滤参数过大时&#xff0c;执行sql由于参数过大而报错&#xff0c;此时 需要使用临时表的方式&#xff0c;即 当参数超过某个阀值&#xff08;如 1000&#xff0c;可调整&#xff09;新增一张临时表&#xff0c;将原表 与 该临时表进…

代码随想录算法训练营第六十二天|503.下一个更大元素II、42.接雨水

代码随想录算法训练营第六十二天|503.下一个更大元素II、42.接雨水 503.下一个更大元素II 给定一个循环数组 nums &#xff08; nums[nums.length - 1] 的下一个元素是 nums[0] &#xff09;&#xff0c;返回 nums 中每个元素的 下一个更大元素 。 数字 x 的 下一个更大的元…

第十一篇:操作系统新纪元:智能融合、量子跃迁与虚拟现实的交响曲

操作系统新纪元&#xff1a;智能融合、量子跃迁与虚拟现实的交响曲 1 引言 在数字化的浪潮中&#xff0c;操作系统如同一位智慧的舵手&#xff0c;引领着信息技术的航船穿越波涛汹涌的海洋。随着人工智能、物联网、量子计算等前沿技术的蓬勃发展&#xff0c;操作系统正站在一个…

富士Apeos 2350 NDA复印机报062 360代码故障

故障描述&#xff1a; 富士Apeos 2350 NDA复印机新机器刚拆箱安装&#xff0c;开机正常&#xff0c;自检扫描头一卡一卡的往前动几下就不动了、扫描灯也不亮扫描头也不能正常复位&#xff1b;按机器的复印键直接报062 360代码&#xff1b; 解答&#xff1a; 此代码为扫描故障&a…

PDF高效编辑:一键批量,PDF转图片的快速解决方案

在数字化时代&#xff0c;PDF文件已成为工作和学习中不可或缺的一部分。然而&#xff0c;有时我们可能需要将PDF转换为图片&#xff0c;以便更轻松地编辑、共享或处理。为了满足这一需求&#xff0c;许多高效的PDF编辑工具应运而生&#xff0c;其中“办公提效工具”一键批量PDF…

【每日八股】淘天一面

&#x1f525; 个人主页: 黑洞晓威 &#x1f600;你不必等到非常厉害&#xff0c;才敢开始&#xff0c;你需要开始&#xff0c;才会变的非常厉害 rocketmq的消息重复发送问题&#xff1f;如何保证幂等&#xff1f; 如何保证幂等性&#xff1a; 消息 Key 设置&#xff1a;不建议…

如何自定义Markdown中插入图片的位置

工作中常常需要在VsCode下写Markdown笔记&#xff0c;在写笔记的过程中不免需要插入图片。  Markdown中插入笔记的操作往往是比较繁琐的&#xff0c;比如&#xff1a;在文档中引用本地某个文件夹下的图片&#xff0c;首先需要你先保存图片到本地路径&#xff0c;然后需要你在文…

Vue-Cli脚手架项目的搭建【新手快速入手】

目录 一、Vue CLI脚手架简介☺ 1.Node.js前置环境的安装 2.安装npm管理器 3.安装淘宝镜像(cnpm) 二、安装vue-cli 1. 版本号查看 2.旧版本卸载 3.新版本安装 4.检查 三、Vue项目的搭建 &#x1f4cc;进入Vue项目管理器 ★命令方式创建 若localhost拒绝访问怎么办&…

技术速递|Python in Visual Studio Code 2024年5月发布

排版&#xff1a;Alan Wang 我们很高兴地宣布 Visual Studio Code 的 Python 和 Jupyter 扩展将于 2024 年 5 月发布&#xff01; 此版本包括以下公告&#xff1a; “Implement all inherited abstract classes”代码操作新的自动缩进设置Debugpy 从 Python 扩展中删除&#…

Unity TileMap入门

概述 相信很多同学学习制作游戏都是从2D游戏开始制作的吧&#xff0c;瓦片地图相信大家都有接触&#xff0c;那接下来让我们学习一下这部分的内容吧&#xff01; Tilemap AnimationFrameRate:设置每帧动画的播放速率。Color:瓦片地图的颜色TileAnchor:锚点&#xff0c;&#x…