C++系列-第1章顺序结构-3-输出类cout
在线练习:
http://noi.openjudge.cn/
https://www.luogu.com.cn/
总结
本文是C++系列博客,主要讲述输出类cout的用法
cout介绍与基本用法
在C++中,cout
是用于输出(打印)数据的工具,它是 ostream
类的对象。cout
允许你将数据发送到标准输出设备,通常是终端或控制台。为了使用 cout
,你需要在程序中包含 <iostream>
头文件。
基本用法
使用 cout
的基本格式如下:
#include <iostream>
int main() {int number = 42;std::cout << "The number is " << number << std::endl;return 0;
}
输出为:
在这个例子中,std::cout
用于打印变量 number
的值。<<
是流插入运算符,用于向输出流中插入数据。std::endl
是一个特殊的操纵符,用于结束当前行并将缓冲区内容刷新到输出设备。
案例演示
1. 打印变量和文本
#include <iostream>
int main() {int x = 10;std::cout << "The value of x is " << x << std::endl;return 0;
}
输出为:
2. 格式化输出
#include <iostream>
#include <iomanip>
int main() {double pi = 3.14159;std::cout << "Pi is " << std::fixed << std::setprecision(2) << pi << std::endl;return 0;
}
输出为:
在这个例子中,std::fixed
和 std::setprecision(2)
用于格式化输出,使得 pi
的值以固定的小数点后两位显示。
3. 多重插入
#include <iostream>
int main() {std::cout << "This is a " << "sentence " << "with multiple " << "insertions." << std::endl;return 0;
}
输出为:
4. 使用不同的输出流
#include <iostream>
#include <fstream>
int main() {std::ofstream myfile("output.txt");std::cout << "This text will go to the file." << std::endl;std::cout << "And this text will go to the console." << std::endl;return 0;
}
在这个例子中,std::ofstream
用于创建一个文件输出流,而 std::cout
用于标准输出。这样,你可以在文件中写入文本,同时也可以在控制台上看到输出。
5. 使用 endl
与 ends
#include <iostream>
int main() {std::cout << "This is a line with an endl" << std::endl;std::cout << "This is a line with an ends" << std::ends;return 0;
}
输出为:
案例-题目2:输出指定数量的空格
题目描述:编写一个程序,根据输入的整数n,输出n个空格。
输入:一个整数n(1≤n≤100)
输出:n个+
样例输入:5
样例输出: (5个空格)
代码:
#include <iostream>
int main() {int n;std::cin >> n;std::cout << std::string(n, '+') << std::endl;return 0;
}
输出为:
案例-题目3:输出倒三角形
题目描述:编写一个程序,根据输入的整数n,输出一个由空格和星号(*)组成的倒三角形。
输入:一个整数n(1≤n≤100)
输出:一个由空格和星号(*)组成的倒三角形
样例输入:5
样例输出:
*************************
代码:
```cpp
#include <iostream>
int main() {int n;std::cin >> n;std::cout << "*********\n";std::cout << " *******\n";std::cout << " *****\n";std::cout << " ***\n";std::cout << " *\n";return 0;
}
输出为:
循环代码:
#include <iostream>
int main() {int n;std::cin >> n;for (int i = n; i >= 1; i--) {std::cout << std::string(n - i + 1, ' ');std::cout << std::string(i * 2 - 1, '*') << std::endl;}return 0;
}