现在越来越多的企业都有自己的无线网络,而无线网络的组网方式一般都是使用AC+AP模式进行组网,使用无线网络能够提供经济、高效的网络接入方式。相比有线网络,无线网络下只要能接入无线网的地方都可以使用网络,用户可以自由移动。而对于AC+AP组网方式来说,转发模式分为本地转发(流量到达AP后直接转发)和集中转发(流量通过隧道到达AC,由AC集中转发)。
实验拓扑及说明
说明:1、SW1和SW2作为AP的DHCP服务器为AP分配IP地址(AP),AC作为STA的DHCP服务器为STA分配IP地址。
2、STA1采用集中转发模式,STA2采用本地转发模式
3、远程网络3.3.3.3位于IP NETWORK路由器上,用于测试数据流向
配置过程略:(文章末尾会附配置文件)
实验现象:1、AP通过交换机SW拿到地址,用于与AC等的通信
2、AP发出两个wlan信号,一个local-forward,一个center-forward
3、STA1连接local-forward信号,这个wlan使用的是本地转发模式工作,业务地址是192.168.1.0/24段。
4、STA2连接center-forward信号,这个wlan使用的是集中转发模式工作,业务地址是192.168.2.0/24段。
5、在远端路由器上开debug,然后在SW与AC之间使用抓包工具抓包,使用集中转发的wlan信号时,流量会经过AC转发,流量到达AP之后通过隧道传给AC,由AC转发。
6、使用本地转发的wlan信号时,流量不会经过AC转发,流量到达AP之后不会封装进隧道发送给AC,而是直接由AP转发。
7、配置文件:
IPNET:
sysname IPNET
interface GigabitEthernet0/0/0
ip address 10.0.12.2 255.255.255.0
#
interface GigabitEthernet0/0/1
ip address 10.0.22.2 255.255.255.0
#
interface NULL0
#
interface LoopBack0
ip address 3.3.3.3 255.255.255.255
#
rip 1
undo summary
version 2
network 10.0.0.0
import-route direct
SW1:
sysname SW1
#
vlan batch 10 100 to 102 1000
#
stp instance 0 root primary
stp instance 1 root secondary
#
dhcp enable
#
stp region-configuration
region-name abc
instance 1 vlan 101
active region-configuration
#
ip pool vlan10
gateway-list 10.0.1.254
network 10.0.1.0 mask 255.255.255.0
option 43 sub-option 2 ip-address 10.0.1.3 10.0.1.4
#
interface Vlanif10
ip address 10.0.1.1 255.255.255.0
vrrp vrid 10 virtual-ip 10.0.1.254
vrrp vrid 10 priority 120
dhcp select global
#
interface Vlanif100
ip address 192.168.1.252 255.255.255.0
vrrp vrid 100 virtual-ip 192.168.1.254
vrrp vrid 100 priority 120
#
interface Vlanif101
ip address 192.168.2.252 255.255.255.0
vrrp vrid 101 virtual-ip 192.168.2.254
#
interface Vlanif1000
ip address 10.0.12.1 255.255.255.0
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 1000
stp disable
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 4094
stp disable
#
interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/24
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface NULL0
#
rip 1
undo summary
version 2
network 10.0.0.0
network 192.168.1.0
network 192.168.2.0
silent-interface GigabitEthernet0/0/2
silent-interface GigabitEthernet0/0/3
SW2:
sysname SW2
#
vlan batch 10 100 to 101 1001
#
stp instance 0 root secondary
stp instance 1 root primary
#
dhcp enable
#
stp region-configuration
region-name abc
instance 1 vlan 101
active region-configuration
#
ip pool vlan10
gateway-list 10.0.1.254
network 10.0.1.0 mask 255.255.255.0
option 43 sub-option 2 ip-address 10.0.1.3 10.0.1.4
#
interface Vlanif10
ip address 10.0.1.2 255.255.255.0
vrrp vrid 10 virtual-ip 10.0.1.254
dhcp select global
#
interface Vlanif100
ip address 192.168.1.253 255.255.255.0
vrrp vrid 100 virtual-ip 192.168.1.254
#
interface Vlanif101
ip address 192.168.2.253 255.255.255.0
vrrp vrid 101 virtual-ip 192.168.2.254
vrrp vrid 101 priority 120
#
interface Vlanif1001
ip address 10.0.22.1 255.255.255.0
#
interface MEth0/0/1
#
interface GigabitEthernet0/0/1
port link-type access
port default vlan 1001
stp disable
#
interface GigabitEthernet0/0/2
port link-type trunk
port trunk allow-pass vlan 2 to 4094
stp disable
#
interface GigabitEthernet0/0/3
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface GigabitEthernet0/0/24
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
interface NULL0
#
rip 1
undo summary
version 2
network 10.0.0.0
network 192.168.1.0
network 192.168.2.0
silent-interface GigabitEthernet0/0/2
silent-interface GigabitEthernet0/0/3
AC1:
sysname AC1
#
vlan batch 10 100 to 101
#
dhcp enable
#
ip pool vlan100
gateway-list 192.168.1.254
network 192.168.1.0 mask 255.255.255.0
#
ip pool vlan101
gateway-list 192.168.2.254
network 192.168.2.0 mask 255.255.255.0
#
interface Vlanif10
ip address 10.0.1.3 255.255.255.0
#
interface Vlanif100
ip address 192.168.1.250 255.255.255.0
dhcp select global
#
interface Vlanif101
ip address 192.168.2.250 255.255.255.0
dhcp select global
#
interface MEth0/0/1
undo negotiation auto
duplex half
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
ip route-static 0.0.0.0 0.0.0.0 10.0.1.254
#
capwap source interface vlanif10
#
wlan
security-profile name wlan-net
ssid-profile name local
ssid local-forward
ssid-profile name center
ssid center-forward
vap-profile name local
service-vlan vlan-id 100
ssid-profile local
security-profile wlan-net
vap-profile name center
forward-mode tunnel
service-vlan vlan-id 101
ssid-profile center
security-profile wlan-net
ap-group name local
radio 0
vap-profile local wlan 1
radio 1
vap-profile center wlan 2
ap-id 0 type-id 56 ap-mac 00e0-fc3e-6f60
ap-name area_1
ap-group local
radio 0
channel 20mhz 6
eirp 127
radio 1
channel 20mhz 149
eirp 127
AC2:
sysname AC2
#
vlan batch 10 100 to 101
#
dhcp enable
#
ip pool vlan100
gateway-list 192.168.1.254
network 192.168.1.0 mask 255.255.255.0
#
ip pool vlan101
gateway-list 192.168.2.254
network 192.168.2.0 mask 255.255.255.0
#
interface Vlanif10
ip address 10.0.1.4 255.255.255.0
#
interface Vlanif100
ip address 192.168.1.251 255.255.255.0
dhcp select global
#
interface Vlanif101
ip address 192.168.2.251 255.255.255.0
dhcp select global
#
interface MEth0/0/1
undo negotiation auto
duplex half
#
interface GigabitEthernet0/0/1
port link-type trunk
port trunk allow-pass vlan 2 to 4094
#
ip route-static 0.0.0.0 0.0.0.0 10.0.1.254
#
capwap source interface vlanif10
#
wlan
security-profile name wlan-net
ssid-profile name local
ssid local-forward
ssid-profile name center
ssid center-forward
vap-profile name local
service-vlan vlan-id 100
ssid-profile local
security-profile wlan-net
vap-profile name center
forward-mode tunnel
service-vlan vlan-id 101
ssid-profile center
security-profile wlan-net
ap-group name local
radio 0
vap-profile local wlan 1
radio 1
vap-profile center wlan 2
ap-id 0 type-id 56 ap-mac 00e0-fc3e-6f60
ap-name area_1
ap-group local
radio 0
channel 20mhz 6
eirp 127
radio 1
channel 20mhz 149
eirp 127