题意:问给出的望塔之间的建造了围墙,将土地分成了几份
思路:用并查集判环,若有围墙相接的瞭望塔,有相同的父根,则存在环
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
Sample Input
8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7
Sample Output
3
#include<iostream>
#include<string.h>
using namespace std;
int m,n,dp[1010];
int f(int xx)
{if(xx==dp[xx])return xx;elsereturn f(dp[xx]);
}
int dfs(int x,int y)
{int a=f(x);int b=f(y);if(a!=b){dp[b]=a;return 0;}elsereturn 1;
}
int main()
{while(cin>>m>>n){int sum=0;for(int i=0; i<m; i++)dp[i]=i;while(n--){int t1,t2;cin>>t1>>t2;sum+=dfs(t1,t2);}cout<<sum<<endl;}return 0;
}